aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/acpica-tools/Makefile5
-rw-r--r--sysutils/acpica-tools/distinfo4
-rw-r--r--sysutils/acpica-tools/files/patch-source-components-utilities-utprint.c22
3 files changed, 27 insertions, 4 deletions
diff --git a/sysutils/acpica-tools/Makefile b/sysutils/acpica-tools/Makefile
index 0aec1cb1b5c9..64e15a9d9e81 100644
--- a/sysutils/acpica-tools/Makefile
+++ b/sysutils/acpica-tools/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= acpica
-PORTVERSION= 20140424
+PORTVERSION= 20140627
CATEGORIES= sysutils devel
MASTER_SITES= https://acpica.org/sites/acpica/files/ \
LOCAL
@@ -12,7 +12,8 @@ DISTNAME= ${PORTNAME}-unix2-${PORTVERSION}
MAINTAINER= jkim@FreeBSD.org
COMMENT= Tools from the ACPI Component Architecture (ACPICA) project
-LICENSE= BSD3CLAUSE
+LICENSE= BSD3CLAUSE GPLv2
+LICENSE_COMB= dual
USES= bison gmake
YACC= ${LOCALBASE}/bin/bison
diff --git a/sysutils/acpica-tools/distinfo b/sysutils/acpica-tools/distinfo
index 06b4d5e33ebc..7a8102a38cd2 100644
--- a/sysutils/acpica-tools/distinfo
+++ b/sysutils/acpica-tools/distinfo
@@ -1,2 +1,2 @@
-SHA256 (acpica-unix2-20140424.tar.gz) = 72ece982bbbdfb1b17418f1feb3a9daaa01803d0d41dcf00e19d702cdf751bbc
-SIZE (acpica-unix2-20140424.tar.gz) = 1272950
+SHA256 (acpica-unix2-20140627.tar.gz) = 1f1054cbd5cb698ebe9b1ad9da26c41062024b6f7ad482db5be1325312b37ba1
+SIZE (acpica-unix2-20140627.tar.gz) = 1291585
diff --git a/sysutils/acpica-tools/files/patch-source-components-utilities-utprint.c b/sysutils/acpica-tools/files/patch-source-components-utilities-utprint.c
new file mode 100644
index 000000000000..b27536e7ab87
--- /dev/null
+++ b/sysutils/acpica-tools/files/patch-source-components-utilities-utprint.c
@@ -0,0 +1,22 @@
+--- ../../source/components/utilities/utprint.c.orig 2014-06-27 11:36:15.000000000 -0400
++++ ../../source/components/utilities/utprint.c 2014-06-27 17:27:55.000000000 -0400
+@@ -298,6 +298,7 @@
+ INT32 Precision,
+ UINT8 Type)
+ {
++ char *Pos;
+ char Sign;
+ char Zero;
+ BOOLEAN NeedPrefix;
+@@ -354,9 +355,8 @@
+
+ /* Generate full string in reverse order */
+
+- i = ACPI_PTR_DIFF (
+- AcpiUtPutNumber (ReversedString, Number, Base, Upper),
+- ReversedString);
++ Pos = AcpiUtPutNumber (ReversedString, Number, Base, Upper);
++ i = ACPI_PTR_DIFF (Pos, ReversedString);
+
+ /* Printing 100 using %2d gives "100", not "00" */
+