aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/mate-control-center/Makefile21
-rw-r--r--sysutils/mate-control-center/distinfo5
-rw-r--r--sysutils/mate-control-center/files/patch-capplets_common_theme-thumbnail.c13
-rw-r--r--sysutils/mate-control-center/pkg-plist13
-rw-r--r--sysutils/mate-polkit/Makefile10
-rw-r--r--sysutils/mate-polkit/distinfo5
-rw-r--r--sysutils/mate-polkit/pkg-plist9
-rw-r--r--sysutils/mate-power-manager/Makefile16
-rw-r--r--sysutils/mate-power-manager/distinfo5
-rw-r--r--sysutils/mate-power-manager/pkg-plist10
-rw-r--r--sysutils/mate-settings-daemon/Makefile22
-rw-r--r--sysutils/mate-settings-daemon/distinfo5
-rw-r--r--sysutils/mate-settings-daemon/pkg-plist9
-rw-r--r--sysutils/mate-system-monitor/Makefile12
-rw-r--r--sysutils/mate-system-monitor/distinfo5
-rw-r--r--sysutils/mate-system-monitor/files/patch-src_lsof.cpp14
-rw-r--r--sysutils/mate-system-monitor/files/patch-src_procproperties.cpp20
-rw-r--r--sysutils/mate-system-monitor/pkg-plist12
18 files changed, 92 insertions, 114 deletions
diff --git a/sysutils/mate-control-center/Makefile b/sysutils/mate-control-center/Makefile
index 3666ac9a3296..dfcac41e22ac 100644
--- a/sysutils/mate-control-center/Makefile
+++ b/sysutils/mate-control-center/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= mate-control-center
-PORTVERSION= 1.12.1
+PORTVERSION= 1.16.0
CATEGORIES= sysutils mate
MASTER_SITES= MATE
DIST_SUBDIR= mate
@@ -12,27 +12,28 @@ COMMENT= Control center for MATE project
BUILD_DEPENDS= itstool:textproc/itstool
LIB_DEPENDS= libcanberra-gtk.so:audio/libcanberra \
+ libcanberra-gtk3.so:audio/libcanberra-gtk3 \
libdbus-1.so:devel/dbus \
libdbus-glib-1.so:devel/dbus-glib \
- libunique-1.0.so:x11-toolkits/unique \
libxklavier.so:x11/libxklavier \
+ libfontconfig.so:x11-fonts/fontconfig \
+ libfreetype.so:print/freetype2 \
+ libstartup-notification-1.so:x11/startup-notification \
+ libunique-3.0.so:x11-toolkits/libunique3 \
libpolkit-gobject-1.so:sysutils/polkit
PORTSCOUT= limitw:1,even
-USES= desktop-file-utils gettext gmake libtool pathfix pkgconfig \
- shared-mime-info tar:xz
+USES= desktop-file-utils gettext gmake libtool localbase \
+ pathfix pkgconfig shared-mime-info tar:xz
USE_MATE= desktop libmatekbd marco menus settingsdaemon
-USE_XORG= x11 xcursor xext xxf86misc xft xi xrandr xscrnsaver
-USE_GNOME= dconf glib20 gtk20 intlhack libxml2 librsvg2 \
- pango
+USE_XORG= ice sm x11 xcursor xext xxf86misc xft xi xrandr xscrnsaver
+USE_GNOME= cairo dconf glib20 gtk30 intlhack libxml2 librsvg2 pango
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-appindicator=no \
- --with-gtk=2.0
+ --with-gtk=3.0
INSTALLS_ICONS= yes
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
INSTALL_TARGET= install-strip
GLIB_SCHEMAS= org.mate.control-center.gschema.xml \
diff --git a/sysutils/mate-control-center/distinfo b/sysutils/mate-control-center/distinfo
index e8615e8e9abc..e0ecfc3b4a2a 100644
--- a/sysutils/mate-control-center/distinfo
+++ b/sysutils/mate-control-center/distinfo
@@ -1,2 +1,3 @@
-SHA256 (mate/mate-control-center-1.12.1.tar.xz) = 851f08e69ec8f513b8971262a439c83ef837b2a7467690313672b6a9d9a179fb
-SIZE (mate/mate-control-center-1.12.1.tar.xz) = 1304732
+TIMESTAMP = 1480009344
+SHA256 (mate/mate-control-center-1.16.0.tar.xz) = 155226a482c3d0e402ec49ca53f6691afc5688df8cc958a5e216827e19525e22
+SIZE (mate/mate-control-center-1.16.0.tar.xz) = 1341724
diff --git a/sysutils/mate-control-center/files/patch-capplets_common_theme-thumbnail.c b/sysutils/mate-control-center/files/patch-capplets_common_theme-thumbnail.c
deleted file mode 100644
index 96123ea4fa57..000000000000
--- a/sysutils/mate-control-center/files/patch-capplets_common_theme-thumbnail.c
+++ /dev/null
@@ -1,13 +0,0 @@
---- ./capplets/common/theme-thumbnail.c.orig 2016-01-09 18:24:24.817763000 +0100
-+++ ./capplets/common/theme-thumbnail.c 2016-01-09 18:25:23.640259000 +0100
-@@ -145,9 +145,7 @@ static GdkPixmap* draw_window_on_pixbuf(
-
- gtk_widget_hide(widget);
-
--#if GTK_CHECK_VERSION (3, 0, 0)
-- return pixbuf;
--#else
-+#if !GTK_CHECK_VERSION (3, 0, 0)
- return pixmap;
- #endif
- }
diff --git a/sysutils/mate-control-center/pkg-plist b/sysutils/mate-control-center/pkg-plist
index 50ad4fecd845..7e831ea1b6fb 100644
--- a/sysutils/mate-control-center/pkg-plist
+++ b/sysutils/mate-control-center/pkg-plist
@@ -12,7 +12,6 @@ bin/mate-network-properties
bin/mate-thumbnail-font
bin/mate-typing-monitor
bin/mate-window-properties
-etc/xdg/menus/mate-preferences-categories.menu
etc/xdg/menus/matecc.menu
include/libmate-slab/app-resizer.h
include/libmate-slab/app-shell.h
@@ -68,7 +67,6 @@ man/man1/mate-thumbnail-font.1.gz
man/man1/mate-typing-monitor.1.gz
man/man1/mate-window-properties.1.gz
sbin/mate-display-properties-install-systemwide
-share/MateConf/gsettings/mate-control-center.convert
share/applications/mate-about-me.desktop
share/applications/mate-appearance-properties.desktop
share/applications/mate-at-properties.desktop
@@ -82,7 +80,6 @@ share/applications/mate-settings-mouse.desktop
share/applications/mate-theme-installer.desktop
share/applications/mate-window-properties.desktop
share/applications/matecc.desktop
-share/applications/mimeinfo.cache
share/desktop-directories/matecc.directory
share/help/C/mate-control-center/config-accessibility-keyboard.xml
share/help/C/mate-control-center/config-background.xml
@@ -426,7 +423,6 @@ share/locale/as/LC_MESSAGES/mate-control-center.mo
share/locale/ast/LC_MESSAGES/mate-control-center.mo
share/locale/az/LC_MESSAGES/mate-control-center.mo
share/locale/be/LC_MESSAGES/mate-control-center.mo
-share/locale/be@latin/LC_MESSAGES/mate-control-center.mo
share/locale/bg/LC_MESSAGES/mate-control-center.mo
share/locale/bn/LC_MESSAGES/mate-control-center.mo
share/locale/bn_IN/LC_MESSAGES/mate-control-center.mo
@@ -442,17 +438,20 @@ share/locale/da/LC_MESSAGES/mate-control-center.mo
share/locale/de/LC_MESSAGES/mate-control-center.mo
share/locale/dz/LC_MESSAGES/mate-control-center.mo
share/locale/el/LC_MESSAGES/mate-control-center.mo
-share/locale/en@shaw/LC_MESSAGES/mate-control-center.mo
share/locale/en_AU/LC_MESSAGES/mate-control-center.mo
share/locale/en_CA/LC_MESSAGES/mate-control-center.mo
share/locale/en_GB/LC_MESSAGES/mate-control-center.mo
share/locale/eo/LC_MESSAGES/mate-control-center.mo
share/locale/es/LC_MESSAGES/mate-control-center.mo
+share/locale/es_CO/LC_MESSAGES/mate-control-center.mo
+share/locale/es_MX/LC_MESSAGES/mate-control-center.mo
share/locale/et/LC_MESSAGES/mate-control-center.mo
share/locale/eu/LC_MESSAGES/mate-control-center.mo
share/locale/fa/LC_MESSAGES/mate-control-center.mo
share/locale/fi/LC_MESSAGES/mate-control-center.mo
share/locale/fr/LC_MESSAGES/mate-control-center.mo
+share/locale/fr_CA/LC_MESSAGES/mate-control-center.mo
+share/locale/frp/LC_MESSAGES/mate-control-center.mo
share/locale/ga/LC_MESSAGES/mate-control-center.mo
share/locale/gl/LC_MESSAGES/mate-control-center.mo
share/locale/gu/LC_MESSAGES/mate-control-center.mo
@@ -460,10 +459,12 @@ share/locale/he/LC_MESSAGES/mate-control-center.mo
share/locale/hi/LC_MESSAGES/mate-control-center.mo
share/locale/hr/LC_MESSAGES/mate-control-center.mo
share/locale/hu/LC_MESSAGES/mate-control-center.mo
+share/locale/hy/LC_MESSAGES/mate-control-center.mo
share/locale/id/LC_MESSAGES/mate-control-center.mo
share/locale/is/LC_MESSAGES/mate-control-center.mo
share/locale/it/LC_MESSAGES/mate-control-center.mo
share/locale/ja/LC_MESSAGES/mate-control-center.mo
+share/locale/jv/LC_MESSAGES/mate-control-center.mo
share/locale/ka/LC_MESSAGES/mate-control-center.mo
share/locale/kk/LC_MESSAGES/mate-control-center.mo
share/locale/kn/LC_MESSAGES/mate-control-center.mo
@@ -489,6 +490,7 @@ share/locale/oc/LC_MESSAGES/mate-control-center.mo
share/locale/or/LC_MESSAGES/mate-control-center.mo
share/locale/pa/LC_MESSAGES/mate-control-center.mo
share/locale/pl/LC_MESSAGES/mate-control-center.mo
+share/locale/pms/LC_MESSAGES/mate-control-center.mo
share/locale/pt/LC_MESSAGES/mate-control-center.mo
share/locale/pt_BR/LC_MESSAGES/mate-control-center.mo
share/locale/ro/LC_MESSAGES/mate-control-center.mo
@@ -509,7 +511,6 @@ share/locale/ug/LC_MESSAGES/mate-control-center.mo
share/locale/uk/LC_MESSAGES/mate-control-center.mo
share/locale/ur/LC_MESSAGES/mate-control-center.mo
share/locale/uz/LC_MESSAGES/mate-control-center.mo
-share/locale/uz@cyrillic/LC_MESSAGES/mate-control-center.mo
share/locale/vi/LC_MESSAGES/mate-control-center.mo
share/locale/wa/LC_MESSAGES/mate-control-center.mo
share/locale/xh/LC_MESSAGES/mate-control-center.mo
diff --git a/sysutils/mate-polkit/Makefile b/sysutils/mate-polkit/Makefile
index 1c8893a1e596..335f240fa926 100644
--- a/sysutils/mate-polkit/Makefile
+++ b/sysutils/mate-polkit/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= mate-polkit
-PORTVERSION= 1.12.0
+PORTVERSION= 1.16.0
CATEGORIES= sysutils mate
MASTER_SITES= MATE
DIST_SUBDIR= mate
@@ -16,16 +16,14 @@ LIB_DEPENDS= libpolkit-gobject-1.so:sysutils/polkit \
PORTSCOUT= limitw:1,even
-USES= gettext gmake libtool pathfix pkgconfig tar:xz
-USE_GNOME= gtk20 intlhack introspection:build
+USES= gettext gmake libtool localbase pathfix \
+ pkgconfig tar:xz
+USE_GNOME= cairo gdkpixbuf2 gtk30 intlhack introspection:build
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-gtk-doc \
- --with-gtk=2.0 \
--enable-accountsservice \
--localstatedir=/var
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
INSTALL_TARGET= install-strip
.include <bsd.port.mk>
diff --git a/sysutils/mate-polkit/distinfo b/sysutils/mate-polkit/distinfo
index bf4650ef552e..bba17210dbd1 100644
--- a/sysutils/mate-polkit/distinfo
+++ b/sysutils/mate-polkit/distinfo
@@ -1,2 +1,3 @@
-SHA256 (mate/mate-polkit-1.12.0.tar.xz) = c38f0a0c3d4e10fc95d27fa4e8d47eb6948e8c9279a82f316f563666571bf8b9
-SIZE (mate/mate-polkit-1.12.0.tar.xz) = 324708
+TIMESTAMP = 1480006561
+SHA256 (mate/mate-polkit-1.16.0.tar.xz) = e0aba1f4be2fef30a74509aef92c5773ee17c2279f158a7295415f700713457c
+SIZE (mate/mate-polkit-1.16.0.tar.xz) = 340500
diff --git a/sysutils/mate-polkit/pkg-plist b/sysutils/mate-polkit/pkg-plist
index fb79665b9b18..1299f0e2d812 100644
--- a/sysutils/mate-polkit/pkg-plist
+++ b/sysutils/mate-polkit/pkg-plist
@@ -13,10 +13,12 @@ share/gir-1.0/PolkitGtkMate-1.0.gir
share/locale/am/LC_MESSAGES/mate-polkit.mo
share/locale/ar/LC_MESSAGES/mate-polkit.mo
share/locale/be/LC_MESSAGES/mate-polkit.mo
+share/locale/bg/LC_MESSAGES/mate-polkit.mo
share/locale/bn_IN/LC_MESSAGES/mate-polkit.mo
share/locale/ca/LC_MESSAGES/mate-polkit.mo
share/locale/cmn/LC_MESSAGES/mate-polkit.mo
share/locale/cs/LC_MESSAGES/mate-polkit.mo
+share/locale/cy/LC_MESSAGES/mate-polkit.mo
share/locale/da/LC_MESSAGES/mate-polkit.mo
share/locale/de/LC_MESSAGES/mate-polkit.mo
share/locale/el/LC_MESSAGES/mate-polkit.mo
@@ -27,13 +29,16 @@ share/locale/et/LC_MESSAGES/mate-polkit.mo
share/locale/eu/LC_MESSAGES/mate-polkit.mo
share/locale/fi/LC_MESSAGES/mate-polkit.mo
share/locale/fr/LC_MESSAGES/mate-polkit.mo
+share/locale/fr_CA/LC_MESSAGES/mate-polkit.mo
share/locale/gl/LC_MESSAGES/mate-polkit.mo
share/locale/gu/LC_MESSAGES/mate-polkit.mo
share/locale/he/LC_MESSAGES/mate-polkit.mo
share/locale/hi/LC_MESSAGES/mate-polkit.mo
share/locale/hr/LC_MESSAGES/mate-polkit.mo
share/locale/hu/LC_MESSAGES/mate-polkit.mo
+share/locale/hy/LC_MESSAGES/mate-polkit.mo
share/locale/id/LC_MESSAGES/mate-polkit.mo
+share/locale/is/LC_MESSAGES/mate-polkit.mo
share/locale/it/LC_MESSAGES/mate-polkit.mo
share/locale/ja/LC_MESSAGES/mate-polkit.mo
share/locale/kk/LC_MESSAGES/mate-polkit.mo
@@ -46,7 +51,9 @@ share/locale/ml/LC_MESSAGES/mate-polkit.mo
share/locale/mr/LC_MESSAGES/mate-polkit.mo
share/locale/ms/LC_MESSAGES/mate-polkit.mo
share/locale/nb/LC_MESSAGES/mate-polkit.mo
+share/locale/ne/LC_MESSAGES/mate-polkit.mo
share/locale/nl/LC_MESSAGES/mate-polkit.mo
+share/locale/oc/LC_MESSAGES/mate-polkit.mo
share/locale/or/LC_MESSAGES/mate-polkit.mo
share/locale/pa/LC_MESSAGES/mate-polkit.mo
share/locale/pl/LC_MESSAGES/mate-polkit.mo
@@ -54,6 +61,7 @@ share/locale/pt/LC_MESSAGES/mate-polkit.mo
share/locale/pt_BR/LC_MESSAGES/mate-polkit.mo
share/locale/ro/LC_MESSAGES/mate-polkit.mo
share/locale/ru/LC_MESSAGES/mate-polkit.mo
+share/locale/si/LC_MESSAGES/mate-polkit.mo
share/locale/sk/LC_MESSAGES/mate-polkit.mo
share/locale/sl/LC_MESSAGES/mate-polkit.mo
share/locale/sq/LC_MESSAGES/mate-polkit.mo
@@ -65,6 +73,7 @@ share/locale/th/LC_MESSAGES/mate-polkit.mo
share/locale/tr/LC_MESSAGES/mate-polkit.mo
share/locale/uk/LC_MESSAGES/mate-polkit.mo
share/locale/ur/LC_MESSAGES/mate-polkit.mo
+share/locale/uz/LC_MESSAGES/mate-polkit.mo
share/locale/zh_CN/LC_MESSAGES/mate-polkit.mo
share/locale/zh_HK/LC_MESSAGES/mate-polkit.mo
share/locale/zh_TW/LC_MESSAGES/mate-polkit.mo
diff --git a/sysutils/mate-power-manager/Makefile b/sysutils/mate-power-manager/Makefile
index 57b73990b82e..20822d5285c4 100644
--- a/sysutils/mate-power-manager/Makefile
+++ b/sysutils/mate-power-manager/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= mate-power-manager
-PORTVERSION= 1.12.1
+PORTVERSION= 1.16.0
CATEGORIES= sysutils mate
MASTER_SITES= MATE
DIST_SUBDIR= mate
@@ -13,30 +13,32 @@ COMMENT= Power management system for the MATE Desktop
BUILD_DEPENDS= itstool:textproc/itstool \
gnome-keyring>=3.0.0:security/gnome-keyring
LIB_DEPENDS= libcanberra-gtk.so:audio/libcanberra \
+ libcanberra-gtk3.so:audio/libcanberra-gtk3 \
libdbus-1.so:devel/dbus \
libdbus-glib-1.so:devel/dbus-glib \
- libunique-1.0.so:x11-toolkits/unique \
libupower-glib.so:sysutils/upower \
+ libfontconfig.so:x11-fonts/fontconfig \
+ libfreetype.so:print/freetype2 \
libnotify.so:devel/libnotify \
+ libunique-3.0.so:x11-toolkits/libunique3 \
libgnome-keyring.so:security/libgnome-keyring
RUN_DEPENDS= pkexec:sysutils/polkit \
gnome-keyring>=3.0.0:security/gnome-keyring
PORTSCOUT= limitw:1,even
-USES= execinfo gettext gmake libtool pathfix pkgconfig tar:xz
+USES= execinfo gettext gmake libtool localbase \
+ pathfix pkgconfig tar:xz
USE_MATE= panel
USE_XORG= x11 xext xproto xrandr xrender
-USE_GNOME= cairo glib20 gtk20 intlhack
+USE_GNOME= cairo glib20 gtk30 intlhack
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
CONFIGURE_ENV= LIBS="-lexecinfo"
CONFIGURE_ARGS= --with-doc-dir=${PREFIX}/share/doc \
--disable-docbook-docs \
- --with-gtk=2.0 \
+ --with-gtk=3.0 \
--with-keyring
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
GLIB_SCHEMAS= org.mate.power-manager.gschema.xml
diff --git a/sysutils/mate-power-manager/distinfo b/sysutils/mate-power-manager/distinfo
index 2a437a505698..767bd778000a 100644
--- a/sysutils/mate-power-manager/distinfo
+++ b/sysutils/mate-power-manager/distinfo
@@ -1,2 +1,3 @@
-SHA256 (mate/mate-power-manager-1.12.1.tar.xz) = c43aa2ae75335a758d71cdab4b939141c352a7fb179c3e41a064ce9c007b587f
-SIZE (mate/mate-power-manager-1.12.1.tar.xz) = 3197824
+TIMESTAMP = 1480011274
+SHA256 (mate/mate-power-manager-1.16.0.tar.xz) = 70449008afb448daf4c18f533d3999f76c642b492594b0eaa751dec749330a3e
+SIZE (mate/mate-power-manager-1.16.0.tar.xz) = 3178780
diff --git a/sysutils/mate-power-manager/pkg-plist b/sysutils/mate-power-manager/pkg-plist
index 7986025f1763..6ded2480be1c 100644
--- a/sysutils/mate-power-manager/pkg-plist
+++ b/sysutils/mate-power-manager/pkg-plist
@@ -5,7 +5,6 @@ etc/xdg/autostart/mate-power-manager.desktop
libexec/mate-brightness-applet
libexec/mate-inhibit-applet
sbin/mate-power-backlight-helper
-share/MateConf/gsettings/mate-power-manager.convert
share/applications/mate-power-preferences.desktop
share/applications/mate-power-statistics.desktop
share/dbus-1/services/org.mate.PowerManager.service
@@ -280,10 +279,10 @@ share/locale/ar/LC_MESSAGES/mate-power-manager.mo
share/locale/as/LC_MESSAGES/mate-power-manager.mo
share/locale/ast/LC_MESSAGES/mate-power-manager.mo
share/locale/be/LC_MESSAGES/mate-power-manager.mo
-share/locale/be@latin/LC_MESSAGES/mate-power-manager.mo
share/locale/bg/LC_MESSAGES/mate-power-manager.mo
share/locale/bn/LC_MESSAGES/mate-power-manager.mo
share/locale/bn_IN/LC_MESSAGES/mate-power-manager.mo
+share/locale/br/LC_MESSAGES/mate-power-manager.mo
share/locale/ca/LC_MESSAGES/mate-power-manager.mo
share/locale/ca@valencia/LC_MESSAGES/mate-power-manager.mo
share/locale/cmn/LC_MESSAGES/mate-power-manager.mo
@@ -293,12 +292,12 @@ share/locale/da/LC_MESSAGES/mate-power-manager.mo
share/locale/de/LC_MESSAGES/mate-power-manager.mo
share/locale/dz/LC_MESSAGES/mate-power-manager.mo
share/locale/el/LC_MESSAGES/mate-power-manager.mo
-share/locale/en@shaw/LC_MESSAGES/mate-power-manager.mo
share/locale/en_AU/LC_MESSAGES/mate-power-manager.mo
share/locale/en_CA/LC_MESSAGES/mate-power-manager.mo
share/locale/en_GB/LC_MESSAGES/mate-power-manager.mo
-share/locale/en_US/LC_MESSAGES/mate-power-manager.mo
share/locale/es/LC_MESSAGES/mate-power-manager.mo
+share/locale/es_CO/LC_MESSAGES/mate-power-manager.mo
+share/locale/es_MX/LC_MESSAGES/mate-power-manager.mo
share/locale/et/LC_MESSAGES/mate-power-manager.mo
share/locale/eu/LC_MESSAGES/mate-power-manager.mo
share/locale/fa/LC_MESSAGES/mate-power-manager.mo
@@ -311,6 +310,7 @@ share/locale/he/LC_MESSAGES/mate-power-manager.mo
share/locale/hi/LC_MESSAGES/mate-power-manager.mo
share/locale/hr/LC_MESSAGES/mate-power-manager.mo
share/locale/hu/LC_MESSAGES/mate-power-manager.mo
+share/locale/hy/LC_MESSAGES/mate-power-manager.mo
share/locale/id/LC_MESSAGES/mate-power-manager.mo
share/locale/is/LC_MESSAGES/mate-power-manager.mo
share/locale/it/LC_MESSAGES/mate-power-manager.mo
@@ -336,6 +336,7 @@ share/locale/oc/LC_MESSAGES/mate-power-manager.mo
share/locale/or/LC_MESSAGES/mate-power-manager.mo
share/locale/pa/LC_MESSAGES/mate-power-manager.mo
share/locale/pl/LC_MESSAGES/mate-power-manager.mo
+share/locale/pms/LC_MESSAGES/mate-power-manager.mo
share/locale/pt/LC_MESSAGES/mate-power-manager.mo
share/locale/pt_BR/LC_MESSAGES/mate-power-manager.mo
share/locale/ro/LC_MESSAGES/mate-power-manager.mo
@@ -353,6 +354,7 @@ share/locale/th/LC_MESSAGES/mate-power-manager.mo
share/locale/tr/LC_MESSAGES/mate-power-manager.mo
share/locale/uk/LC_MESSAGES/mate-power-manager.mo
share/locale/ur/LC_MESSAGES/mate-power-manager.mo
+share/locale/uz/LC_MESSAGES/mate-power-manager.mo
share/locale/vi/LC_MESSAGES/mate-power-manager.mo
share/locale/zh_CN/LC_MESSAGES/mate-power-manager.mo
share/locale/zh_HK/LC_MESSAGES/mate-power-manager.mo
diff --git a/sysutils/mate-settings-daemon/Makefile b/sysutils/mate-settings-daemon/Makefile
index d25574230bbd..58dcf1d39d62 100644
--- a/sysutils/mate-settings-daemon/Makefile
+++ b/sysutils/mate-settings-daemon/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= mate-settings-daemon
-PORTVERSION= 1.12.1
-PORTREVISION= 1
+PORTVERSION= 1.16.0
CATEGORIES= sysutils mate
MASTER_SITES= MATE
DIST_SUBDIR= mate
@@ -15,26 +14,29 @@ LIB_DEPENDS= libdbus-1.so:devel/dbus \
libdbus-glib-1.so:devel/dbus-glib \
libxklavier.so:x11/libxklavier \
libnss3.so:security/nss \
+ libfreetype.so:print/freetype2 \
libfontconfig.so:x11-fonts/fontconfig \
libpolkit-gobject-1.so:sysutils/polkit \
+ libstartup-notification-1.so:x11/startup-notification \
+ libcanberra-gtk.so:audio/libcanberra \
+ libcanberra-gtk3.so:audio/libcanberra-gtk3 \
+ libnspr4.so:devel/nspr \
libnotify.so:devel/libnotify
RUN_DEPENDS= xrdb:x11/xrdb
PORTSCOUT= limitw:1,even
-USES= gettext gmake libtool pathfix pkgconfig tar:xz
-USE_MATE= desktop libmatekbd
-USE_XORG= xxf86misc
-USE_GNOME= dconf gtk20 intlhack
+USES= gettext gmake libtool localbase pathfix \
+ pkgconfig tar:xz
+USE_MATE= desktop libmatekbd mixer
+USE_XORG= ice sm x11 xext xi xxf86misc
+USE_GNOME= cairo dconf gtk30 intlhack
USE_LDCONFIG= yes
-USE_GSTREAMER= good
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-dbus-services=${PREFIX}/share/dbus-1/services \
- --with-gtk=2.0 \
+ --with-gtk=3.0 \
--disable-static
INSTALLS_ICONS= yes
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
INSTALL_TARGET= install-strip
GLIB_SCHEMAS= org.mate.SettingsDaemon.plugins.a11y-keyboard.gschema.xml \
diff --git a/sysutils/mate-settings-daemon/distinfo b/sysutils/mate-settings-daemon/distinfo
index cf3a70dee076..812a1b023e93 100644
--- a/sysutils/mate-settings-daemon/distinfo
+++ b/sysutils/mate-settings-daemon/distinfo
@@ -1,2 +1,3 @@
-SHA256 (mate/mate-settings-daemon-1.12.1.tar.xz) = a0d9ea55ba5828500e873eff6c771dae645fa3218c1ba9d701c408f0eb71e988
-SIZE (mate/mate-settings-daemon-1.12.1.tar.xz) = 781388
+TIMESTAMP = 1480007497
+SHA256 (mate/mate-settings-daemon-1.16.0.tar.xz) = 7876b7377adb89a11812c1b3fd44e1e78f371f8418f4f05bf5be25ea8efce4d0
+SIZE (mate/mate-settings-daemon-1.16.0.tar.xz) = 767136
diff --git a/sysutils/mate-settings-daemon/pkg-plist b/sysutils/mate-settings-daemon/pkg-plist
index e505a4d76b1b..78c7da61e1f0 100644
--- a/sysutils/mate-settings-daemon/pkg-plist
+++ b/sysutils/mate-settings-daemon/pkg-plist
@@ -47,7 +47,6 @@ libexec/msd-locate-pointer
man/man1/mate-settings-daemon.1.gz
man/man1/msd-datetime-mechanism.1.gz
man/man1/msd-locate-pointer.1.gz
-share/MateConf/gsettings/mate-settings-daemon.convert
share/dbus-1/services/org.mate.SettingsDaemon.service
share/dbus-1/system-services/org.mate.SettingsDaemon.DateTimeMechanism.service
share/icons/hicolor/16x16/apps/msd-xrandr.png
@@ -72,7 +71,6 @@ share/locale/as/LC_MESSAGES/mate-settings-daemon.mo
share/locale/ast/LC_MESSAGES/mate-settings-daemon.mo
share/locale/az/LC_MESSAGES/mate-settings-daemon.mo
share/locale/be/LC_MESSAGES/mate-settings-daemon.mo
-share/locale/be@latin/LC_MESSAGES/mate-settings-daemon.mo
share/locale/bg/LC_MESSAGES/mate-settings-daemon.mo
share/locale/bn/LC_MESSAGES/mate-settings-daemon.mo
share/locale/bn_IN/LC_MESSAGES/mate-settings-daemon.mo
@@ -88,17 +86,17 @@ share/locale/da/LC_MESSAGES/mate-settings-daemon.mo
share/locale/de/LC_MESSAGES/mate-settings-daemon.mo
share/locale/dz/LC_MESSAGES/mate-settings-daemon.mo
share/locale/el/LC_MESSAGES/mate-settings-daemon.mo
-share/locale/en@shaw/LC_MESSAGES/mate-settings-daemon.mo
share/locale/en_AU/LC_MESSAGES/mate-settings-daemon.mo
share/locale/en_CA/LC_MESSAGES/mate-settings-daemon.mo
share/locale/en_GB/LC_MESSAGES/mate-settings-daemon.mo
-share/locale/en_US/LC_MESSAGES/mate-settings-daemon.mo
share/locale/es/LC_MESSAGES/mate-settings-daemon.mo
+share/locale/es_CO/LC_MESSAGES/mate-settings-daemon.mo
share/locale/et/LC_MESSAGES/mate-settings-daemon.mo
share/locale/eu/LC_MESSAGES/mate-settings-daemon.mo
share/locale/fa/LC_MESSAGES/mate-settings-daemon.mo
share/locale/fi/LC_MESSAGES/mate-settings-daemon.mo
share/locale/fr/LC_MESSAGES/mate-settings-daemon.mo
+share/locale/frp/LC_MESSAGES/mate-settings-daemon.mo
share/locale/ga/LC_MESSAGES/mate-settings-daemon.mo
share/locale/gl/LC_MESSAGES/mate-settings-daemon.mo
share/locale/gu/LC_MESSAGES/mate-settings-daemon.mo
@@ -106,6 +104,7 @@ share/locale/he/LC_MESSAGES/mate-settings-daemon.mo
share/locale/hi/LC_MESSAGES/mate-settings-daemon.mo
share/locale/hr/LC_MESSAGES/mate-settings-daemon.mo
share/locale/hu/LC_MESSAGES/mate-settings-daemon.mo
+share/locale/hy/LC_MESSAGES/mate-settings-daemon.mo
share/locale/id/LC_MESSAGES/mate-settings-daemon.mo
share/locale/is/LC_MESSAGES/mate-settings-daemon.mo
share/locale/it/LC_MESSAGES/mate-settings-daemon.mo
@@ -135,6 +134,7 @@ share/locale/oc/LC_MESSAGES/mate-settings-daemon.mo
share/locale/or/LC_MESSAGES/mate-settings-daemon.mo
share/locale/pa/LC_MESSAGES/mate-settings-daemon.mo
share/locale/pl/LC_MESSAGES/mate-settings-daemon.mo
+share/locale/pms/LC_MESSAGES/mate-settings-daemon.mo
share/locale/pt/LC_MESSAGES/mate-settings-daemon.mo
share/locale/pt_BR/LC_MESSAGES/mate-settings-daemon.mo
share/locale/ro/LC_MESSAGES/mate-settings-daemon.mo
@@ -153,6 +153,7 @@ share/locale/th/LC_MESSAGES/mate-settings-daemon.mo
share/locale/tr/LC_MESSAGES/mate-settings-daemon.mo
share/locale/uk/LC_MESSAGES/mate-settings-daemon.mo
share/locale/ur/LC_MESSAGES/mate-settings-daemon.mo
+share/locale/uz/LC_MESSAGES/mate-settings-daemon.mo
share/locale/vi/LC_MESSAGES/mate-settings-daemon.mo
share/locale/wa/LC_MESSAGES/mate-settings-daemon.mo
share/locale/xh/LC_MESSAGES/mate-settings-daemon.mo
diff --git a/sysutils/mate-system-monitor/Makefile b/sysutils/mate-system-monitor/Makefile
index dbeb340ceca8..6498df9b8da2 100644
--- a/sysutils/mate-system-monitor/Makefile
+++ b/sysutils/mate-system-monitor/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= mate-system-monitor
-PORTVERSION= 1.12.1
+PORTVERSION= 1.16.0
CATEGORIES= sysutils mate
MASTER_SITES= MATE
DIST_SUBDIR= mate
@@ -16,15 +16,13 @@ LIB_DEPENDS= libgtop-2.0.so:devel/libgtop \
PORTSCOUT= limitw:1,even
-USES= alias compiler:c++11-lang gettext gmake pathfix \
- pkgconfig tar:xz
+USES= alias compiler:c++11-lib gettext gmake localbase \
+ pathfix pkgconfig tar:xz
USE_MATE= icontheme
-USE_GNOME= gtk20 gtkmm24 intlhack librsvg2 libwnck libxml2
-CONFIGURE_ARGS= --with-gtk=2.0
+USE_GNOME= gtkmm30 intlhack librsvg2 libwnck3 libxml2
GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --disable-systemd
CONFIGURE_ENV= LIBS="-lutil" DATADIRNAME="share"
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
GLIB_SCHEMAS= org.mate.system-monitor.enums.xml \
org.mate.system-monitor.gschema.xml
diff --git a/sysutils/mate-system-monitor/distinfo b/sysutils/mate-system-monitor/distinfo
index 6b462172d5eb..b6973ab74f32 100644
--- a/sysutils/mate-system-monitor/distinfo
+++ b/sysutils/mate-system-monitor/distinfo
@@ -1,2 +1,3 @@
-SHA256 (mate/mate-system-monitor-1.12.1.tar.xz) = 7668ecba70b7f56f3bcfb143cb6b93a15daf8636fcf678491112afea1a49dea9
-SIZE (mate/mate-system-monitor-1.12.1.tar.xz) = 2113756
+TIMESTAMP = 1480011826
+SHA256 (mate/mate-system-monitor-1.16.0.tar.xz) = abbbfeba699f73a6eacb7545927693daba4fb6203a75170a93df4842cacd9fe1
+SIZE (mate/mate-system-monitor-1.16.0.tar.xz) = 2120984
diff --git a/sysutils/mate-system-monitor/files/patch-src_lsof.cpp b/sysutils/mate-system-monitor/files/patch-src_lsof.cpp
deleted file mode 100644
index 9c32166eb360..000000000000
--- a/sysutils/mate-system-monitor/files/patch-src_lsof.cpp
+++ /dev/null
@@ -1,14 +0,0 @@
---- src/lsof.cpp.orig 2015-09-25 13:36:19.000000000 +0200
-+++ src/lsof.cpp 2016-01-09 12:32:53.892273000 +0100
-@@ -140,8 +140,9 @@
-
- void update_count(unsigned count)
- {
-- string s = static_cast<std::ostringstream&>(std::ostringstream() << count).str();
-- gtk_label_set_text(this->count, s.c_str());
-+ std::ostringstream ss;
-+ ss << count;;
-+ gtk_label_set_text(this->count, ss.str().c_str());
- }
-
-
diff --git a/sysutils/mate-system-monitor/files/patch-src_procproperties.cpp b/sysutils/mate-system-monitor/files/patch-src_procproperties.cpp
deleted file mode 100644
index 7daeab5c60d6..000000000000
--- a/sysutils/mate-system-monitor/files/patch-src_procproperties.cpp
+++ /dev/null
@@ -1,20 +0,0 @@
---- src/procproperties.cpp.orig 2015-07-02 23:46:27.000000000 +0200
-+++ src/procproperties.cpp 2015-07-14 10:18:48.273918000 +0200
-@@ -26,7 +26,7 @@
- #include <glibtop/procstate.h>
- #if defined (__linux__)
- #include <asm/param.h>
--#elif defined (__NetBSD__) || defined (__OpenBSD__)
-+#elif defined (__NetBSD__) || defined (__OpenBSD__) || defined(__FreeBSD__) || defined(__FreeBSD_kernel__)
- #include <sys/param.h>
- #include <sys/sysctl.h>
- #endif
-@@ -114,7 +114,7 @@
-
- get_process_memory_info(info);
-
--#if defined (__NetBSD__) || defined (__OpenBSD__)
-+#if defined (__NetBSD__) || defined (__OpenBSD__) || defined(__FreeBSD__) || defined(__FreeBSD_kernel__)
- struct clockinfo cinf;
- size_t size = sizeof (cinf);
- int HZ;
diff --git a/sysutils/mate-system-monitor/pkg-plist b/sysutils/mate-system-monitor/pkg-plist
index 3aa31cd9e7d4..c599b4234216 100644
--- a/sysutils/mate-system-monitor/pkg-plist
+++ b/sysutils/mate-system-monitor/pkg-plist
@@ -1,6 +1,5 @@
bin/mate-system-monitor
man/man1/mate-system-monitor.1.gz
-share/MateConf/gsettings/mate-system-monitor.convert
share/appdata/mate-system-monitor.appdata.xml
share/applications/mate-system-monitor.desktop
share/help/C/mate-system-monitor/figures/addColumn.png
@@ -219,10 +218,10 @@ share/locale/as/LC_MESSAGES/mate-system-monitor.mo
share/locale/ast/LC_MESSAGES/mate-system-monitor.mo
share/locale/az/LC_MESSAGES/mate-system-monitor.mo
share/locale/be/LC_MESSAGES/mate-system-monitor.mo
-share/locale/be@latin/LC_MESSAGES/mate-system-monitor.mo
share/locale/bg/LC_MESSAGES/mate-system-monitor.mo
share/locale/bn/LC_MESSAGES/mate-system-monitor.mo
share/locale/bn_IN/LC_MESSAGES/mate-system-monitor.mo
+share/locale/br/LC_MESSAGES/mate-system-monitor.mo
share/locale/bs/LC_MESSAGES/mate-system-monitor.mo
share/locale/ca/LC_MESSAGES/mate-system-monitor.mo
share/locale/ca@valencia/LC_MESSAGES/mate-system-monitor.mo
@@ -233,18 +232,20 @@ share/locale/da/LC_MESSAGES/mate-system-monitor.mo
share/locale/de/LC_MESSAGES/mate-system-monitor.mo
share/locale/dz/LC_MESSAGES/mate-system-monitor.mo
share/locale/el/LC_MESSAGES/mate-system-monitor.mo
-share/locale/en@shaw/LC_MESSAGES/mate-system-monitor.mo
share/locale/en_AU/LC_MESSAGES/mate-system-monitor.mo
share/locale/en_CA/LC_MESSAGES/mate-system-monitor.mo
share/locale/en_GB/LC_MESSAGES/mate-system-monitor.mo
share/locale/eo/LC_MESSAGES/mate-system-monitor.mo
share/locale/es/LC_MESSAGES/mate-system-monitor.mo
+share/locale/es_CO/LC_MESSAGES/mate-system-monitor.mo
share/locale/es_MX/LC_MESSAGES/mate-system-monitor.mo
share/locale/et/LC_MESSAGES/mate-system-monitor.mo
share/locale/eu/LC_MESSAGES/mate-system-monitor.mo
share/locale/fa/LC_MESSAGES/mate-system-monitor.mo
share/locale/fi/LC_MESSAGES/mate-system-monitor.mo
share/locale/fr/LC_MESSAGES/mate-system-monitor.mo
+share/locale/fr_CA/LC_MESSAGES/mate-system-monitor.mo
+share/locale/frp/LC_MESSAGES/mate-system-monitor.mo
share/locale/ga/LC_MESSAGES/mate-system-monitor.mo
share/locale/gl/LC_MESSAGES/mate-system-monitor.mo
share/locale/gu/LC_MESSAGES/mate-system-monitor.mo
@@ -252,9 +253,12 @@ share/locale/he/LC_MESSAGES/mate-system-monitor.mo
share/locale/hi/LC_MESSAGES/mate-system-monitor.mo
share/locale/hr/LC_MESSAGES/mate-system-monitor.mo
share/locale/hu/LC_MESSAGES/mate-system-monitor.mo
+share/locale/hy/LC_MESSAGES/mate-system-monitor.mo
share/locale/id/LC_MESSAGES/mate-system-monitor.mo
+share/locale/is/LC_MESSAGES/mate-system-monitor.mo
share/locale/it/LC_MESSAGES/mate-system-monitor.mo
share/locale/ja/LC_MESSAGES/mate-system-monitor.mo
+share/locale/jv/LC_MESSAGES/mate-system-monitor.mo
share/locale/ka/LC_MESSAGES/mate-system-monitor.mo
share/locale/kk/LC_MESSAGES/mate-system-monitor.mo
share/locale/kn/LC_MESSAGES/mate-system-monitor.mo
@@ -281,6 +285,7 @@ share/locale/oc/LC_MESSAGES/mate-system-monitor.mo
share/locale/or/LC_MESSAGES/mate-system-monitor.mo
share/locale/pa/LC_MESSAGES/mate-system-monitor.mo
share/locale/pl/LC_MESSAGES/mate-system-monitor.mo
+share/locale/pms/LC_MESSAGES/mate-system-monitor.mo
share/locale/ps/LC_MESSAGES/mate-system-monitor.mo
share/locale/pt/LC_MESSAGES/mate-system-monitor.mo
share/locale/pt_BR/LC_MESSAGES/mate-system-monitor.mo
@@ -301,6 +306,7 @@ share/locale/tr/LC_MESSAGES/mate-system-monitor.mo
share/locale/ug/LC_MESSAGES/mate-system-monitor.mo
share/locale/uk/LC_MESSAGES/mate-system-monitor.mo
share/locale/ur/LC_MESSAGES/mate-system-monitor.mo
+share/locale/uz/LC_MESSAGES/mate-system-monitor.mo
share/locale/vi/LC_MESSAGES/mate-system-monitor.mo
share/locale/zh_CN/LC_MESSAGES/mate-system-monitor.mo
share/locale/zh_HK/LC_MESSAGES/mate-system-monitor.mo