aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/915resolution/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/sysutils/915resolution/Makefile b/sysutils/915resolution/Makefile
index c46f77280eb9..2a47c618b114 100644
--- a/sysutils/915resolution/Makefile
+++ b/sysutils/915resolution/Makefile
@@ -19,6 +19,14 @@ COMMENT= Resolution tool for Intel i915 video cards
PLIST_FILES= bin/915resolution
ALL_TARGET= 915resolution
+ONLY_FOR_ARCHS= i386
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= Does not build
+.endif
+
do-build:
cd ${WRKSRC} && \
${CC} ${CFLAGS} 915resolution.c -o 915resolution
@@ -26,4 +34,4 @@ do-build:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/915resolution ${PREFIX}/bin
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>