aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/bsdinfo/Makefile29
-rw-r--r--sysutils/bsdinfo/distinfo2
-rw-r--r--sysutils/bsdinfo/pkg-descr7
4 files changed, 39 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 280972916fb1..8f06011600ef 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -82,6 +82,7 @@
SUBDIR += bsdconfig
SUBDIR += bsdcrashtar
SUBDIR += bsdhwmon
+ SUBDIR += bsdinfo
SUBDIR += bsdmoted
SUBDIR += bsdsar
SUBDIR += bsdstats
diff --git a/sysutils/bsdinfo/Makefile b/sysutils/bsdinfo/Makefile
new file mode 100644
index 000000000000..b73fb1a4e2d3
--- /dev/null
+++ b/sysutils/bsdinfo/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: bsdinfo
+# Date created: 8 June 2012
+# Whom: samu <s@samu.pl>
+#
+# $FreeBSD$
+#
+
+PORTNAME= bsdinfo
+PORTVERSION= 0.22
+CATEGORIES= sysutils
+MASTER_SITES= http://cloud.github.com/downloads/samaelszafran/bsdinfo/
+
+MAINTAINER= s@samu.pl
+COMMENT= A simple utility to display system-based information
+
+GNU_CONFIGURE= yes
+
+OPTIONS_DEFINE= X256
+X256_DESC= Build the 256 color version
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MX256}
+CONFIGURE_ARGS+=--x256
+.endif
+
+PLIST_FILES+= bin/bsdinfo
+
+.include <bsd.port.mk>
diff --git a/sysutils/bsdinfo/distinfo b/sysutils/bsdinfo/distinfo
new file mode 100644
index 000000000000..e742f7add888
--- /dev/null
+++ b/sysutils/bsdinfo/distinfo
@@ -0,0 +1,2 @@
+SHA256 (bsdinfo-0.22.tar.gz) = d9856f23f53ab67374e394a279576c20b97377252807390ae70f5ec7de936ae7
+SIZE (bsdinfo-0.22.tar.gz) = 4305
diff --git a/sysutils/bsdinfo/pkg-descr b/sysutils/bsdinfo/pkg-descr
new file mode 100644
index 000000000000..2ad1c7546dee
--- /dev/null
+++ b/sysutils/bsdinfo/pkg-descr
@@ -0,0 +1,7 @@
+This is a FreeBSD attempt to implement archey-like terminal system information
+display utility. It is just an esthetic way to display system information.
+Right now it doesn't have any configurable options (different themes, switches
+to change behaviour, etc), but I will add such features in the future,
+perhaps.
+
+WWW: https://github.com/samaelszafran/bsdinfo