aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/hatop/Makefile36
-rw-r--r--sysutils/hatop/distinfo3
-rw-r--r--sysutils/hatop/pkg-descr12
4 files changed, 52 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index f1cc5d9d0918..c5955c0749e3 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -348,6 +348,7 @@
SUBDIR += hal
SUBDIR += hal-info
SUBDIR += hammerhead
+ SUBDIR += hatop
SUBDIR += hdup
SUBDIR += healthd
SUBDIR += heartbeat
diff --git a/sysutils/hatop/Makefile b/sysutils/hatop/Makefile
new file mode 100644
index 000000000000..f1d53f144772
--- /dev/null
+++ b/sysutils/hatop/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: hatop
+# Date created: 2010-08-16
+# Whom: Jim Riggs <ports@christianserving.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= hatop
+PORTVERSION= 0.7.6
+CATEGORIES= sysutils net
+MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
+
+MAINTAINER= ports@christianserving.org
+COMMENT= An interactive real-time monitoring tool for the HAProxy unix socket
+
+RUN_DEPENDS= ${LOCALBASE}/sbin/haproxy:${PORTSDIR}/net/haproxy
+
+USE_PYTHON= yes
+NO_BUILD= yes
+
+LICENSE= GPLv3
+
+PLIST_FILES= bin/hatop
+PORTDOCS= HACKING KEYBINDS README
+
+MAN1= hatop.1
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/bin/hatop ${PREFIX}/bin/hatop
+ ${INSTALL_MAN} ${WRKSRC}/man/hatop.1 ${MAN1PREFIX}/man/man1
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ (cd ${WRKSRC} && ${COPYTREE_SHARE} "${PORTDOCS}" ${DOCSDIR})
+.endif
+
+.include <bsd.port.mk>
diff --git a/sysutils/hatop/distinfo b/sysutils/hatop/distinfo
new file mode 100644
index 000000000000..c04727958187
--- /dev/null
+++ b/sysutils/hatop/distinfo
@@ -0,0 +1,3 @@
+MD5 (hatop-0.7.6.tar.gz) = 5703d153962cdac09ae2309ec06179ab
+SHA256 (hatop-0.7.6.tar.gz) = d2db73535cbf20f7b5d333f3d153eaabb9ed3c765c6666630f96c580c00b19d3
+SIZE (hatop-0.7.6.tar.gz) = 132364
diff --git a/sysutils/hatop/pkg-descr b/sysutils/hatop/pkg-descr
new file mode 100644
index 000000000000..c521873ec63d
--- /dev/null
+++ b/sysutils/hatop/pkg-descr
@@ -0,0 +1,12 @@
+HATop is an interactive ncurses client and real-time monitoring
+statistics displaying tool for the HAProxy unix socket.
+
+HATop's appearance is similar to top. It supports various modes for
+detailed statistics of all configured proxies and services in near
+realtime. In addition, it features an interactive CLI for the haproxy
+unix socket. This allows administrators to control the given haproxy
+instance (change server weight, put servers into maintenance mode,
+etc.) directly out of hatop (using keybinds or the CLI) and monitor the
+results immediately.
+
+WWW: http://feurix.org/projects/hatop/