aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/munin-common/distinfo6
-rw-r--r--sysutils/munin-common/files/patch-Makefile36
-rw-r--r--sysutils/munin-common/files/patch-Makefile.config12
-rw-r--r--sysutils/munin-common/files/patch-plugins_node.d_multiping.in4
-rw-r--r--sysutils/munin-common/munin.mk2
5 files changed, 24 insertions, 36 deletions
diff --git a/sysutils/munin-common/distinfo b/sysutils/munin-common/distinfo
index ee16f18f6aaf..6ae871383090 100644
--- a/sysutils/munin-common/distinfo
+++ b/sysutils/munin-common/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1542802138
-SHA256 (munin-2.0.43.tar.gz) = 17d788ce0b3d633b22d5f54086fb5de53d52e82bc1cdd53d55c2e0aa95151549
-SIZE (munin-2.0.43.tar.gz) = 2257914
+TIMESTAMP = 1545649130
+SHA256 (munin-2.0.44.tar.gz) = 43358cc381ca53f0a756ddac39c3a2d122a4f35ce0f358ece95c5da2054268c0
+SIZE (munin-2.0.44.tar.gz) = 2258278
diff --git a/sysutils/munin-common/files/patch-Makefile b/sysutils/munin-common/files/patch-Makefile
index af88a5dd9a56..e51e51608938 100644
--- a/sysutils/munin-common/files/patch-Makefile
+++ b/sysutils/munin-common/files/patch-Makefile
@@ -1,8 +1,8 @@
---- Makefile.orig 2018-09-21 02:11:11 UTC
+--- Makefile.orig 2018-12-19 20:56:49 UTC
+++ Makefile
-@@ -93,60 +93,47 @@ install: install-master-prime install-co
+@@ -96,60 +96,47 @@ install: install-master-prime install-common-prime ins
- install-pre: Makefile Makefile.config
+ install-pre: $(MAKEFILES)
@$(CHECKUSER)
- mkdir -p $(LOGDIR)
- mkdir -p $(STATEDIR)
@@ -24,12 +24,6 @@
- mkdir -p $(DBDIR)
- mkdir -p $(DBDIR)/cgi-tmp
- mkdir -p $(CGIDIR)
--
-- $(CHOWN) $(USER) $(HTMLDIR) $(DBDIR)
-- $(CHMOD) 0755 $(DBDIR)
--
-- $(CHOWN) $(CGIUSER) $(DBDIR)/cgi-tmp
-- $(CHMOD) 0755 $(DBDIR)/cgi-tmp
+ mkdir -p $(DESTDIR)$(CONFDIR)/templates
+ mkdir -p $(DESTDIR)$(CONFDIR)/static
+ mkdir -p $(DESTDIR)$(CONFDIR)/templates/partial
@@ -40,6 +34,12 @@
+ mkdir -p $(DESTDIR)$(DBDIR)/cgi-tmp
+ mkdir -p $(DESTDIR)$(CGIDIR)
+- $(CHOWN) $(USER) $(HTMLDIR) $(DBDIR)
+- $(CHMOD) 0755 $(DBDIR)
+-
+- $(CHOWN) $(CGIUSER) $(DBDIR)/cgi-tmp
+- $(CHMOD) 0755 $(DBDIR)/cgi-tmp
+-
for p in master/www/*.tmpl ; do \
- $(INSTALL) -m 0644 "$$p" $(CONFDIR)/templates/ ; \
+ $(INSTALL) -m 0644 "$$p" $(DESTDIR)$(CONFDIR)/templates/ ; \
@@ -88,23 +88,23 @@
# Not ready to be installed yet
# $(INSTALL) -m 0755 build/master/_bin/munin-gather $(LIBDIR)/
-@@ -156,36 +143,30 @@ install-node-plugins: install-plugins-pr
- install-plugins-prime: install-plugins build $(PLUGINS) Makefile Makefile.config
+@@ -159,36 +146,30 @@ install-node-plugins: install-plugins-prime
+ install-plugins-prime: install-plugins build $(PLUGINS) $(MAKEFILES)
@$(CHECKGROUP)
- mkdir -p $(CONFDIR)/plugins
- mkdir -p $(CONFDIR)/plugin-conf.d
- mkdir -p $(LIBDIR)/plugins
- mkdir -p $(PLUGSTATE)
--
-- $(CHOWN) root:root $(PLUGSTATE)
-- $(CHMOD) 0755 $(PLUGSTATE)
-- $(CHMOD) 0755 $(CONFDIR)/plugin-conf.d
+ mkdir -p $(DESTDIR)$(CONFDIR)/plugins
+ mkdir -p $(DESTDIR)$(CONFDIR)/plugin-conf.d
+ mkdir -p $(DESTDIR)$(LIBDIR)/plugins
+ mkdir -p $(DESTDIR)$(PLUGSTATE)
+- $(CHOWN) root:root $(PLUGSTATE)
+- $(CHMOD) 0755 $(PLUGSTATE)
+- $(CHMOD) 0755 $(CONFDIR)/plugin-conf.d
+-
@# Process the OS specific plugins at the end. Otherwise they would be overridden by the
@# generic ones.
for p in build/plugins/node.d/* build/plugins/node.d.$(OSTYPE)/* ; do \
@@ -136,7 +136,7 @@
fi \
done
-@@ -196,14 +177,14 @@ install-plugins-java: build-plugins-java
+@@ -199,14 +180,14 @@ install-plugins-java: build-plugins-java
install-async-prime: install-async
install-async:
@@ -155,7 +155,7 @@
install-common-prime: build-common install-common
-@@ -516,7 +497,7 @@ t/install:
+@@ -519,7 +500,7 @@ t/install:
# This builds */Build from Build.PL
%/Build: %/Build.PL
@@ -164,7 +164,7 @@
build-%: %/Build
cd $* && $(PERL) Build
-@@ -532,6 +513,7 @@ install-%: %/Build
+@@ -535,6 +516,7 @@ install-%: %/Build
--install_path script=$(BINDIR) \
--install_path sbin=$(SBINDIR) \
--install_path bindoc=$(MANDIR)/man1 \
diff --git a/sysutils/munin-common/files/patch-Makefile.config b/sysutils/munin-common/files/patch-Makefile.config
index fa776a6fa861..db0c45144d5e 100644
--- a/sysutils/munin-common/files/patch-Makefile.config
+++ b/sysutils/munin-common/files/patch-Makefile.config
@@ -91,15 +91,3 @@
# Server only - Where to install the perl libraries
PERLLIB = $(DESTDIR)$(shell $(PERL) -V:sitelib | cut -d"'" -f2)
-@@ -128,9 +128,8 @@ CGIUSER := nobody
- # Which command to use to check if the USER and GROUP to run Munin as, exists.
- # These will work on most modern OSes:
- #
--GETENT := $(shell which getent || which true 2>/dev/null)
--CHECKUSER := $(shell $(GETENT) passwd $(USER) >/dev/null 2>/dev/null || (echo "echo User $(USER) nonexistent. Create the user and retry; exit 2"))
--CHECKGROUP := $(shell $(GETENT) group $(GROUP) >/dev/null 2>/dev/null || (echo "echo Group $(GROUP) nonexistent. Create the group and retry; exit 2"))
-+CHECKUSER:= $(shell /usr/sbin/pw user show $(USER) >/dev/null 2>/dev/null || (echo "echo User $(USER) nonexistant. Create the user and retry; exit 2"))
-+CHECKGROUP:= $(shell /usr/sbin/pw group show $(GROUP) >/dev/null 2>/dev/null || (echo "echo Group $(GROUP) nonexistant. Create the group and retry; exit 2"))
-
- # For OSX, comment out the previous two lines and comment in these
- #
diff --git a/sysutils/munin-common/files/patch-plugins_node.d_multiping.in b/sysutils/munin-common/files/patch-plugins_node.d_multiping.in
index 6e48ca346605..f14d4bde3724 100644
--- a/sysutils/munin-common/files/patch-plugins_node.d_multiping.in
+++ b/sysutils/munin-common/files/patch-plugins_node.d_multiping.in
@@ -1,6 +1,6 @@
---- plugins/node.d/multiping.in.orig 2018-07-24 11:34:38 UTC
+--- plugins/node.d/multiping.in.orig 2018-12-19 20:56:49 UTC
+++ plugins/node.d/multiping.in
-@@ -58,6 +58,7 @@ Foundation, Inc., 51 Franklin Street, Fi
+@@ -58,6 +58,7 @@ Foundation, Inc., 51 Franklin Street, Fifth Floor, Bos
host=${host:-www.google.com}
diff --git a/sysutils/munin-common/munin.mk b/sysutils/munin-common/munin.mk
index cc528e1e7a65..af122537dc8b 100644
--- a/sysutils/munin-common/munin.mk
+++ b/sysutils/munin-common/munin.mk
@@ -1,6 +1,6 @@
LICENSE= GPLv2
-MUNIN_VERSION= 2.0.43
+MUNIN_VERSION= 2.0.44
MUNIN_SITES= http://downloads.munin-monitoring.org/munin/stable/${MUNIN_VERSION}/
DISTINFO_FILE= ${.CURDIR}/../../sysutils/munin-common/distinfo
PATCHDIR= ${.CURDIR}/../../sysutils/munin-common/files