aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/aspell
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/aspell')
-rw-r--r--textproc/aspell/Makefile148
-rw-r--r--textproc/aspell/distinfo19
-rw-r--r--textproc/aspell/pkg-message31
-rw-r--r--textproc/aspell/pkg-plist1
-rw-r--r--textproc/aspell/pkg-plist.br6
-rw-r--r--textproc/aspell/pkg-plist.ca4
-rw-r--r--textproc/aspell/pkg-plist.cs4
-rw-r--r--textproc/aspell/pkg-plist.da6
-rw-r--r--textproc/aspell/pkg-plist.de11
-rw-r--r--textproc/aspell/pkg-plist.en20
-rw-r--r--textproc/aspell/pkg-plist.eo4
-rw-r--r--textproc/aspell/pkg-plist.es6
-rw-r--r--textproc/aspell/pkg-plist.fo6
-rw-r--r--textproc/aspell/pkg-plist.fr48
-rw-r--r--textproc/aspell/pkg-plist.it4
-rw-r--r--textproc/aspell/pkg-plist.nl4
-rw-r--r--textproc/aspell/pkg-plist.no5
-rw-r--r--textproc/aspell/pkg-plist.pl4
-rw-r--r--textproc/aspell/pkg-plist.pt10
-rw-r--r--textproc/aspell/pkg-plist.ro6
-rw-r--r--textproc/aspell/pkg-plist.ru5
-rw-r--r--textproc/aspell/pkg-plist.sk4
-rw-r--r--textproc/aspell/pkg-plist.sv6
23 files changed, 323 insertions, 39 deletions
diff --git a/textproc/aspell/Makefile b/textproc/aspell/Makefile
index 52eeb53bc7d1..7d66a4ed21c7 100644
--- a/textproc/aspell/Makefile
+++ b/textproc/aspell/Makefile
@@ -5,16 +5,19 @@
# $FreeBSD$
#
-PORTNAME= aspell
+PORTNAME?= aspell
PORTVERSION= 0.50.1
-CATEGORIES= textproc
+CATEGORIES+= textproc
MASTER_SITES= http://savannah.gnu.org/download/${PORTNAME}/rel/ \
${MASTER_SITE_GNU}
-MASTER_SITE_SUBDIR= ${PORTNAME}
+MASTER_SITE_SUBDIR= aspell
+DISTFILES= aspell-0.50.1.tar.gz # needed for slave ports / options
+EXTRACT_ONLY= aspell-0.50.1.tar.gz
-MAINTAINER= thierry@pompo.net
+MAINTAINER?= thierry@pompo.net
-BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash2
+BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash2 \
+ bzip2:${PORTSDIR}/archivers/bzip2
USE_LIBTOOL= yes
CONFIGURE_ARGS= --enable-dict-dir=${DATADIR} \
@@ -26,8 +29,139 @@ MAKE_ARGS= NOPORTDOCS=${NOPORTDOCS}
INSTALLS_SHLIB= yes
PLIST_SUB= PORTVERSION=${PORTVERSION}
+WRKSRC= ${WRKDIR}/aspell-${PORTVERSION} # needed for slave ports / options
+DOCSDIR= ${PREFIX}/share/doc/aspell
+DATADIR= ${PREFIX}/share/aspell
+COMMENT= ${.CURDIR}/pkg-comment
+DESCR= ${.CURDIR}/pkg-descr
+
+CONF_DICT_ENV= ASPELL="${PREFIX}/bin/aspell" \
+ WORD_LIST_COMPRESS="${PREFIX}/bin/word-list-compress"
+DICT_DIR= -${DICTVERSION}-${DICTREVISION}
+DICT_SUFFIX= ${DICT_DIR}.tar.bz2
+AVAIL_DICT= br ca cs da de en eo es fo fr it nl no pl pt ro ru sk sv
+DICTVERSION= 0.50
+DICTREVISION= 2
+
+.include <bsd.port.pre.mk>
+
+.if defined(LANG)
+DEF_DICT!= ${ECHO_CMD} ${LANG} | ${CUT} -c 1-2
+.else
+DEF_DICT= en
+.endif
+
+pre-everything::
+.if (!defined(ASPELL_BR) && !defined(ASPELL_CA) && !defined(ASPELL_CS) && !defined(ASPELL_DA) && !defined(ASPELL_DE) && !defined(ASPELL_EN) && !defined(ASPELL_EO) && !defined(ASPELL_ES) && !defined(ASPELL_FO) && !defined(ASPELL_FR) && !defined(ASPELL_IT) && !defined(ASPELL_NL) && !defined(ASPELL_NO) && !defined(ASPELL_PL) && !defined(ASPELL_PT) && !defined(ASPELL_RO) && !defined(ASPELL_RU) && !defined(ASPELL_SK) && !defined(ASPELL_SV))
+ @${ECHO_MSG} '*********************************************************'
+ @${ECHO_MSG} '* You can add further dictionaries: *'
+ @${ECHO_MSG} '* Use make-flag: *'
+ @${ECHO_MSG} '* - Breton ASPELL_BR=yes *'
+ @${ECHO_MSG} '* - Catalan ASPELL_CA=yes *'
+ @${ECHO_MSG} '* - Czech ASPELL_CS=yes *'
+ @${ECHO_MSG} '* - Danish ASPELL_DA=yes *'
+ @${ECHO_MSG} '* - German ASPELL_DE=yes *'
+ @${ECHO_MSG} '* - English ASPELL_EN=yes *'
+ @${ECHO_MSG} '* - Esperanto ASPELL_EO=yes *'
+ @${ECHO_MSG} '* - Spanish ASPELL_ES=yes *'
+ @${ECHO_MSG} '* - Faroese ASPELL_FO=yes *'
+ @${ECHO_MSG} '* - French ASPELL_FR=yes *'
+ @${ECHO_MSG} '* - Italian ASPELL_IT=yes *'
+ @${ECHO_MSG} '* - Dutch ASPELL_NL=yes *'
+ @${ECHO_MSG} '* - Norwegian ASPELL_NO=yes *'
+ @${ECHO_MSG} '* - Polish ASPELL_PL=yes *'
+ @${ECHO_MSG} '* - Portuguese ASPELL_PT=yes *'
+ @${ECHO_MSG} '* - Romanian ASPELL_RO=yes *'
+ @${ECHO_MSG} '* - Russian ASPELL_RU=yes *'
+ @${ECHO_MSG} '* - Slovak ASPELL_SK=yes *'
+ @${ECHO_MSG} '* - Swedish ASPELL_SV=yes *'
+ @${ECHO_MSG} '* *'
+ @${ECHO_MSG} '* Example: "make ASPELL_FR=yes ASPELL_EN=yes install" *'
+ @${ECHO_MSG} '*********************************************************'
+.else
+.if defined(ASPELL_BR)
+DICTS+= br
+.endif
+.if defined(ASPELL_CA)
+DICTS+= ca
+.endif
+.if defined(ASPELL_CS)
+DICTS+= cs
+.endif
+.if defined(ASPELL_DA)
+DICTS+= da
+.endif
+.if defined(ASPELL_DE)
+DICTS+= de
+.endif
+.if defined(ASPELL_EN)
+DICTS+= en
+.endif
+.if defined(ASPELL_EO)
+DICTS+= eo
+.endif
+.if defined(ASPELL_ES)
+DICTS+= es
+.endif
+.if defined(ASPELL_FO)
+DICTS+= fo
+.endif
+.if defined(ASPELL_FR)
+DICTS+= fr
+.endif
+.if defined(ASPELL_IT)
+DICTS+= it
+.endif
+.if defined(ASPELL_NL)
+DICTS+= nl
+.endif
+.if defined(ASPELL_NO)
+DICTS+= no
+.endif
+.if defined(ASPELL_PL)
+DICTS+= pl
+.endif
+.if defined(ASPELL_PT)
+DICTS+= pt
+.endif
+.if defined(ASPELL_RO)
+DICTS+= ro
+.endif
+.if defined(ASPELL_RU)
+DICTS+= ru
+.endif
+.if defined(ASPELL_SK)
+DICTS+= sk
+.endif
+.if defined(ASPELL_SV)
+DICTS+= sv
+.endif
+.endif
+.if !defined(DICTS)
+.for LG in ${AVAIL_DICT}
+.if (${DEF_DICT} == ${LG})
+DICTS= ${LG}
+.endif
+.endfor
+.endif
+.for DICO in ${DICTS}
+DISTFILES+= aspell-${DICO}${DICT_SUFFIX}
+.endfor
+
+post-extract:
+.for DICO in ${DICTS}
+ @cd ${WRKDIR} && \
+ ${TAR} -xjf ${DISTDIR}/aspell-${DICO}${DICT_SUFFIX}
+.endfor
post-install:
- @${CAT} ${PKGMESSAGE}
+.for DICO in ${DICTS}
+ @${ECHO_MSG} "===> Installing for ${DICO} dictionaries"
+ @cd ${WRKDIR}/aspell-${DICO}${DICT_DIR} && \
+ ${CONF_DICT_ENV} ./${CONFIGURE_SCRIPT} && \
+ ${GMAKE} install
+ @${CAT} ${MASTERDIR}/pkg-plist.${DICO} >> ${TMPPLIST}
+.endfor
+ @${ECHO_CMD} "@dirrm share/aspell" >> ${TMPPLIST}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/textproc/aspell/distinfo b/textproc/aspell/distinfo
index 2eda1f28f5dc..1c9c297d3e78 100644
--- a/textproc/aspell/distinfo
+++ b/textproc/aspell/distinfo
@@ -1 +1,20 @@
MD5 (aspell-0.50.1.tar.gz) = 16b3fa4965e03847b4bb629ec83ed3d9
+MD5 (aspell-br-0.50-2.tar.bz2) = 800c7a28e09bd7734d1501cb7a91ad8f
+MD5 (aspell-ca-0.50-2.tar.bz2) = c593ae266d3e48e4d482ff9b9a52acdd
+MD5 (aspell-cs-0.50-2.tar.bz2) = ac4ea210149e6b312b63a862c27df5b4
+MD5 (aspell-da-0.50-2.tar.bz2) = c023f246ef448128e6a3b93388ed57e7
+MD5 (aspell-de-0.50-2.tar.bz2) = 204a9737ff0110fb8c7d284bd7200f7d
+MD5 (aspell-en-0.50-2.tar.bz2) = 9cee7464f9e6e2eae42443048cd3c855
+MD5 (aspell-eo-0.50-2.tar.bz2) = f84147f5909e1a5f7adb86f27c71eb8c
+MD5 (aspell-es-0.50-2.tar.bz2) = 4a8583e9ef9f4aed03f5a7fe09d40060
+MD5 (aspell-fo-0.50-2.tar.bz2) = 9a1031062c72ffce7dac284ed0006a02
+MD5 (aspell-fr-0.50-2.tar.bz2) = 10da01938ec743b16e1dbf0d9abaffbf
+MD5 (aspell-it-0.50-2.tar.bz2) = efa602e47fc49db2cc670f7e5c1628e1
+MD5 (aspell-nl-0.50-2.tar.bz2) = c3ef9fd7dc4c47d816eee9ef5149c76a
+MD5 (aspell-no-0.50-2.tar.bz2) = b24b20ad02ce2a569f71f949b48823cc
+MD5 (aspell-pl-0.50-2.tar.bz2) = a56f6f7e0ad8eb2dce9e8724b2c7496e
+MD5 (aspell-pt-0.50-2.tar.bz2) = e4e15179f90b76ec0336b687d1293edd
+MD5 (aspell-ro-0.50-2.tar.bz2) = 96d97a79a0a0e04c580e0d0671d650c9
+MD5 (aspell-ru-0.50-2.tar.bz2) = d7add85adeef2ea36457ea811d52c295
+MD5 (aspell-sk-0.50-2.tar.bz2) = 8f4db7bf8ffe8c49cd16621620a43240
+MD5 (aspell-sv-0.50-2.tar.bz2) = 8d50ddf72f750d187b0ffc440328db84
diff --git a/textproc/aspell/pkg-message b/textproc/aspell/pkg-message
index 05e821749b0a..e69de29bb2d1 100644
--- a/textproc/aspell/pkg-message
+++ b/textproc/aspell/pkg-message
@@ -1,31 +0,0 @@
-
-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
-Note: don't forget to install dictionaries!
- e.g. for English, see port textproc/aspell-dict
- for French, see port french/aspell
- or go to <URL:http://aspell.sourceforge.net/>.
-
-Warning: Upgrading from Aspell .33/Pspell .12
-
-The way dictionaries are handled has also changed. This includes a change
-in the naming conventions of both language names and dictionaries. Due to
-the language name change, your old personal dictionaries will not be
-recognized. However, you can import the old dictionaries by running the
-"aspell-import" script. This also means that dictionaries designed to
-work with older versions of Aspell are not likely to function correctly.
-Fortunately new dictionary packages are available for most languages. You
-can find them off of the Aspell home page at http://aspell.net.
-
-The Pspell ABI is now part of Aspell except that the name of everything
-has changed due to the renaming of Pspell to Aspell. In particular please
-note the following name changes:
-
- pspell -> aspell
- manager -> speller
- emulation -> enumeration
- master_word_list -> main_word_list
-
-Please also note that the name of the language-tag option has changed to
-lang. However, for backward compatible the language-tag option will still
-work.
-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
diff --git a/textproc/aspell/pkg-plist b/textproc/aspell/pkg-plist
index 1dfa84916936..4d7c34807860 100644
--- a/textproc/aspell/pkg-plist
+++ b/textproc/aspell/pkg-plist
@@ -95,7 +95,6 @@ share/aspell/viscii.dat
%%PORTDOCS%%share/doc/aspell/manual.tex
%%PORTDOCS%%share/doc/aspell/manual2.lyx
@dirrm include/pspell
-@dirrm share/aspell
@dirrm %%PORTDOCS%%share/doc/aspell/dev-html
@dirrm %%PORTDOCS%%share/doc/aspell/dev-text
@dirrm %%PORTDOCS%%share/doc/aspell/man-html
diff --git a/textproc/aspell/pkg-plist.br b/textproc/aspell/pkg-plist.br
new file mode 100644
index 000000000000..eee93b62c029
--- /dev/null
+++ b/textproc/aspell/pkg-plist.br
@@ -0,0 +1,6 @@
+share/aspell/br.dat
+share/aspell/br.multi
+share/aspell/br.rws
+share/aspell/br_phonet.dat
+share/aspell/breton.alias
+share/aspell/brezhoneg.alias
diff --git a/textproc/aspell/pkg-plist.ca b/textproc/aspell/pkg-plist.ca
new file mode 100644
index 000000000000..3f402c486efc
--- /dev/null
+++ b/textproc/aspell/pkg-plist.ca
@@ -0,0 +1,4 @@
+share/aspell/ca.dat
+share/aspell/ca.multi
+share/aspell/ca.rws
+share/aspell/catalan.alias
diff --git a/textproc/aspell/pkg-plist.cs b/textproc/aspell/pkg-plist.cs
new file mode 100644
index 000000000000..3911d4065558
--- /dev/null
+++ b/textproc/aspell/pkg-plist.cs
@@ -0,0 +1,4 @@
+share/aspell/cs.dat
+share/aspell/cs.multi
+share/aspell/cs.rws
+share/aspell/czech.alias
diff --git a/textproc/aspell/pkg-plist.da b/textproc/aspell/pkg-plist.da
new file mode 100644
index 000000000000..b7c0537b6790
--- /dev/null
+++ b/textproc/aspell/pkg-plist.da
@@ -0,0 +1,6 @@
+share/aspell/da.dat
+share/aspell/da.multi
+share/aspell/da.rws
+share/aspell/da_phonet.dat
+share/aspell/danish.alias
+share/aspell/dansk.alias
diff --git a/textproc/aspell/pkg-plist.de b/textproc/aspell/pkg-plist.de
new file mode 100644
index 000000000000..7f659232e96c
--- /dev/null
+++ b/textproc/aspell/pkg-plist.de
@@ -0,0 +1,11 @@
+share/aspell/de-only.rws
+share/aspell/de.dat
+share/aspell/de.multi
+share/aspell/de_CH-only.rws
+share/aspell/de_CH.multi
+share/aspell/de_DE-only.rws
+share/aspell/de_DE.multi
+share/aspell/de_phonet.dat
+share/aspell/deutsch.alias
+share/aspell/german.alias
+share/aspell/swiss.alias
diff --git a/textproc/aspell/pkg-plist.en b/textproc/aspell/pkg-plist.en
new file mode 100644
index 000000000000..96fab462af42
--- /dev/null
+++ b/textproc/aspell/pkg-plist.en
@@ -0,0 +1,20 @@
+share/aspell/american-w-accents.alias
+share/aspell/american.alias
+share/aspell/british-w-accents.alias
+share/aspell/british.alias
+share/aspell/canadian-w-accents.alias
+share/aspell/canadian.alias
+share/aspell/en-only.rws
+share/aspell/en.dat
+share/aspell/en.multi
+share/aspell/en_CA-only.rws
+share/aspell/en_CA-w-accents.multi
+share/aspell/en_CA.multi
+share/aspell/en_GB-only.rws
+share/aspell/en_GB-w-accents.multi
+share/aspell/en_GB.multi
+share/aspell/en_US-only.rws
+share/aspell/en_US-w-accents.multi
+share/aspell/en_US.multi
+share/aspell/en_phonet.dat
+share/aspell/english.alias
diff --git a/textproc/aspell/pkg-plist.eo b/textproc/aspell/pkg-plist.eo
new file mode 100644
index 000000000000..f074128b804a
--- /dev/null
+++ b/textproc/aspell/pkg-plist.eo
@@ -0,0 +1,4 @@
+share/aspell/eo.dat
+share/aspell/eo.multi
+share/aspell/eo.rws
+share/aspell/esperanto.alias
diff --git a/textproc/aspell/pkg-plist.es b/textproc/aspell/pkg-plist.es
new file mode 100644
index 000000000000..0491b02437c9
--- /dev/null
+++ b/textproc/aspell/pkg-plist.es
@@ -0,0 +1,6 @@
+share/aspell/es.dat
+share/aspell/es.multi
+share/aspell/es.rws
+share/aspell/español.alias
+share/aspell/esponol.alias
+share/aspell/spanish.alias
diff --git a/textproc/aspell/pkg-plist.fo b/textproc/aspell/pkg-plist.fo
new file mode 100644
index 000000000000..ff5fa4b8ee38
--- /dev/null
+++ b/textproc/aspell/pkg-plist.fo
@@ -0,0 +1,6 @@
+share/aspell/faroese.alias
+share/aspell/fo.dat
+share/aspell/fo.multi
+share/aspell/fo.rws
+share/aspell/fo_phonet.dat
+share/aspell/fĝroyskt.alias
diff --git a/textproc/aspell/pkg-plist.fr b/textproc/aspell/pkg-plist.fr
new file mode 100644
index 000000000000..7bb770aa6e8b
--- /dev/null
+++ b/textproc/aspell/pkg-plist.fr
@@ -0,0 +1,48 @@
+share/aspell/fr-40-only.rws
+share/aspell/fr-40.multi
+share/aspell/fr-60-only.rws
+share/aspell/fr-60.multi
+share/aspell/fr-80-only.rws
+share/aspell/fr-80.multi
+share/aspell/fr-lrg.alias
+share/aspell/fr-med.alias
+share/aspell/fr-sml.alias
+share/aspell/fr.alias
+share/aspell/fr.dat
+share/aspell/fr_CH-40.multi
+share/aspell/fr_CH-60.multi
+share/aspell/fr_CH-80.multi
+share/aspell/fr_CH-lrg.alias
+share/aspell/fr_CH-med.alias
+share/aspell/fr_CH-only.rws
+share/aspell/fr_CH-sml.alias
+share/aspell/fr_CH.alias
+share/aspell/fr_FR-40.multi
+share/aspell/fr_FR-60.multi
+share/aspell/fr_FR-80.multi
+share/aspell/fr_FR-lrg.alias
+share/aspell/fr_FR-med.alias
+share/aspell/fr_FR-sml.alias
+share/aspell/fr_FR.alias
+share/aspell/fr_phonet.dat
+share/aspell/francais-40.alias
+share/aspell/francais-60.alias
+share/aspell/francais-80.alias
+share/aspell/francais-lrg.alias
+share/aspell/francais-med.alias
+share/aspell/francais-sml.alias
+share/aspell/francais.alias
+share/aspell/french-40.alias
+share/aspell/french-60.alias
+share/aspell/french-80.alias
+share/aspell/french-lrg.alias
+share/aspell/french-med.alias
+share/aspell/french-sml.alias
+share/aspell/french.alias
+share/aspell/suisse-40.alias
+share/aspell/suisse-60.alias
+share/aspell/suisse-80.alias
+share/aspell/suisse-lrg.alias
+share/aspell/suisse-med.alias
+share/aspell/suisse-sml.alias
+share/aspell/suisse.alias
diff --git a/textproc/aspell/pkg-plist.it b/textproc/aspell/pkg-plist.it
new file mode 100644
index 000000000000..6b9f49f26a48
--- /dev/null
+++ b/textproc/aspell/pkg-plist.it
@@ -0,0 +1,4 @@
+share/aspell/it.dat
+share/aspell/it.multi
+share/aspell/it.rws
+share/aspell/italian.alias
diff --git a/textproc/aspell/pkg-plist.nl b/textproc/aspell/pkg-plist.nl
new file mode 100644
index 000000000000..cfbb4e9f578f
--- /dev/null
+++ b/textproc/aspell/pkg-plist.nl
@@ -0,0 +1,4 @@
+share/aspell/dutch.alias
+share/aspell/nl.dat
+share/aspell/nl.multi
+share/aspell/nl.rws
diff --git a/textproc/aspell/pkg-plist.no b/textproc/aspell/pkg-plist.no
new file mode 100644
index 000000000000..b20bfca91a84
--- /dev/null
+++ b/textproc/aspell/pkg-plist.no
@@ -0,0 +1,5 @@
+share/aspell/no.dat
+share/aspell/no.multi
+share/aspell/no.rws
+share/aspell/norsk.alias
+share/aspell/norwegian.alias
diff --git a/textproc/aspell/pkg-plist.pl b/textproc/aspell/pkg-plist.pl
new file mode 100644
index 000000000000..c846f6bd5c6a
--- /dev/null
+++ b/textproc/aspell/pkg-plist.pl
@@ -0,0 +1,4 @@
+share/aspell/pl.dat
+share/aspell/pl.multi
+share/aspell/pl.rws
+share/aspell/polish.alias
diff --git a/textproc/aspell/pkg-plist.pt b/textproc/aspell/pkg-plist.pt
new file mode 100644
index 000000000000..62dbc3abce9f
--- /dev/null
+++ b/textproc/aspell/pkg-plist.pt
@@ -0,0 +1,10 @@
+share/aspell/brazilian.alias
+share/aspell/português.alias
+share/aspell/portuguese.alias
+share/aspell/pt-only.rws
+share/aspell/pt.dat
+share/aspell/pt.multi
+share/aspell/pt_BR-only.rws
+share/aspell/pt_BR.multi
+share/aspell/pt_PT-only.rws
+share/aspell/pt_PT.multi
diff --git a/textproc/aspell/pkg-plist.ro b/textproc/aspell/pkg-plist.ro
new file mode 100644
index 000000000000..f826b9917a40
--- /dev/null
+++ b/textproc/aspell/pkg-plist.ro
@@ -0,0 +1,6 @@
+share/aspell/ro.dat
+share/aspell/ro.multi
+share/aspell/ro.rws
+share/aspell/romaneste.alias
+share/aspell/româneşte.alias
+share/aspell/romanian.alias
diff --git a/textproc/aspell/pkg-plist.ru b/textproc/aspell/pkg-plist.ru
new file mode 100644
index 000000000000..581b640d967d
--- /dev/null
+++ b/textproc/aspell/pkg-plist.ru
@@ -0,0 +1,5 @@
+share/aspell/ru.dat
+share/aspell/ru.multi
+share/aspell/ru.rws
+share/aspell/ru_phonet.dat
+share/aspell/russian.alias
diff --git a/textproc/aspell/pkg-plist.sk b/textproc/aspell/pkg-plist.sk
new file mode 100644
index 000000000000..066195a4dfea
--- /dev/null
+++ b/textproc/aspell/pkg-plist.sk
@@ -0,0 +1,4 @@
+share/aspell/sk.dat
+share/aspell/sk.multi
+share/aspell/sk.rws
+share/aspell/slovak.alias
diff --git a/textproc/aspell/pkg-plist.sv b/textproc/aspell/pkg-plist.sv
new file mode 100644
index 000000000000..77b133378223
--- /dev/null
+++ b/textproc/aspell/pkg-plist.sv
@@ -0,0 +1,6 @@
+share/aspell/sv.dat
+share/aspell/sv.multi
+share/aspell/sv.rws
+share/aspell/sv_phonet.dat
+share/aspell/svenska.alias
+share/aspell/swedish.alias