aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/bib2html/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/bib2html/Makefile')
-rw-r--r--textproc/bib2html/Makefile24
1 files changed, 11 insertions, 13 deletions
diff --git a/textproc/bib2html/Makefile b/textproc/bib2html/Makefile
index 3ab830fe5c37..919e34516364 100644
--- a/textproc/bib2html/Makefile
+++ b/textproc/bib2html/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= bib2html
-PORTVERSION= 1.1
+PORTVERSION= 3.3
CATEGORIES= textproc print
MASTER_SITES= http://galland.stephane.free.fr/arakhne.org/bib2html/ \
http://fresh.t-systems-sfr.com/unix/src/privat2/
@@ -15,23 +15,21 @@ MASTER_SITES= http://galland.stephane.free.fr/arakhne.org/bib2html/ \
MAINTAINER= ports@FreeBSD.org
COMMENT= The BibTeX to HTML Translator
-USE_REINPLACE= yes
-USE_PERL5_RUN= yes
-NO_BUILD= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/src
-PLIST_FILES= bin/bib2html
+USE_PERL5_RUN= yes
+NO_BUILD= yes
post-patch:
- @${REINPLACE_CMD} -e "s|%%SITE_PERL%%|${SITE_PERL}|" ${WRKSRC}/bib2html.pl
+ @${SED} -e 's:= "$$0";:= "${SITE_PERL}/Bib2HTML";:g' \
+ < ${WRKSRC}/bib2html.pl > ${WRKSRC}/bib2html
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/bib2html.pl ${PREFIX}/bin/bib2html
- @${MKDIR} ${SITE_PERL}
- ${CP} -R ${WRKSRC}/Bib2HTML ${SITE_PERL}
- @${FIND} ${SITE_PERL}/Bib2HTML -type f | \
- ${SED} "s,^${PREFIX}/,," >> ${TMPPLIST}
- @${FIND} ${SITE_PERL}/Bib2HTML -type d | ${SORT} -r | \
- ${SED} "s,^${PREFIX}/,@dirrm ," >> ${TMPPLIST}
+ ${INSTALL_SCRIPT} ${WRKSRC}/bib2html ${PREFIX}/bin
+ @${MKDIR} ${SITE_PERL}/Bib2HTML
+ @cd ${WRKSRC}/Bib2HTML && ${FIND} . | \
+ ${CPIO} -pdm -L -R ${LIBOWN}:${LIBGRP} ${SITE_PERL}/Bib2HTML
+ ${FIND} ${SITE_PERL}/Bib2HTML -type f | ${XARGS} ${CHMOD} ${LIBMODE}
+ ${FIND} ${SITE_PERL}/Bib2HTML -type d | ${XARGS} ${CHMOD} a+rx
.include <bsd.port.mk>