aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/cdiff/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/cdiff/Makefile')
-rw-r--r--textproc/cdiff/Makefile17
1 files changed, 14 insertions, 3 deletions
diff --git a/textproc/cdiff/Makefile b/textproc/cdiff/Makefile
index 0c7e52084563..4861179cbcc8 100644
--- a/textproc/cdiff/Makefile
+++ b/textproc/cdiff/Makefile
@@ -2,21 +2,32 @@
# $FreeBSD$
PORTNAME= cdiff
-PORTVERSION= 0.9.3
-PORTREVISION= 1
+PORTVERSION= 0.9.3.20131211
PORTEPOCH= 1
+MASTER_SITES= LOCAL/mat GH GHC
CATEGORIES= textproc
MAINTAINER= mat@FreeBSD.org
COMMENT= Diff readability enhancer for color terminals
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
USE_GITHUB=
GH_ACCOUNT= ymattw
GH_TAGNAME= ${GH_COMMIT}
-GH_COMMIT= f85a5e2
+GH_COMMIT= 14632a1
USE_PYTHON=
USE_PYDISTUTILS=
PYDISTUTILS_AUTOPLIST=
+OPTIONS_DEFINE= DOCS
+
+PORTDOCS= README.rst
+
+post-install:
+ ${INSTALL} -d ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} ${STAGEDIR}${DOCSDIR}
+
.include <bsd.port.mk>