aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/cmark/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/cmark/Makefile')
-rw-r--r--textproc/cmark/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/textproc/cmark/Makefile b/textproc/cmark/Makefile
index 91678ee17c23..1e41e99b0855 100644
--- a/textproc/cmark/Makefile
+++ b/textproc/cmark/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= cmark
-PORTVERSION= 0.25.2
+PORTVERSION= 0.26.1
CATEGORIES= textproc
MAINTAINER= t@tobik.me
@@ -11,6 +11,10 @@ COMMENT= CommonMark parsing and rendering library and program in C
LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/COPYING
+TEST_DEPENDS= python3:lang/python3
+
+TEST_TARGET= test
+
USE_GITHUB= yes
GH_ACCOUNT= jgm
@@ -19,4 +23,6 @@ USE_LDCONFIG= yes
CMAKE_ARGS= -DCMAKE_INSTALL_MANDIR=${MANPREFIX}/man
+PLIST_SUB= VERSION=${PORTVERSION}
+
.include <bsd.port.mk>