aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/diffutils/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/diffutils/Makefile')
-rw-r--r--textproc/diffutils/Makefile38
1 files changed, 20 insertions, 18 deletions
diff --git a/textproc/diffutils/Makefile b/textproc/diffutils/Makefile
index 02f117691b97..ac3c6eaef519 100644
--- a/textproc/diffutils/Makefile
+++ b/textproc/diffutils/Makefile
@@ -6,34 +6,36 @@
#
PORTNAME= diffutils
-PORTVERSION= 2.7
+PORTVERSION= 2.8.1
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= diffutils
-MAINTAINER= rooneg@electricjellyfish.net
+MAINTAINER= ports@freebsd.org
COMMENT= The GNU diff utilities
USE_REINPLACE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --program-prefix=g
+CONFIGURE_ARGS= --program-prefix=g
-INSTALL_INFO?= install-info
+INFO= diff
-post-extract: remove-info-files
+MAN1= gcmp.1 gdiff.1 gdiff3.1 gsdiff.1
-remove-info-files:
- @${RM} -f ${WRKSRC}/${PORTNAME:S/utils//}.info*
-
-post-patch: patch-makeinfo
-
-patch-makeinfo:
- @${REINPLACE_CMD} -e 's|makeinfo|makeinfo --no-split|g' \
- ${WRKSRC}/Makefile.in
-
-post-install: install-info
-
-install-info:
- @${INSTALL_INFO} ${PREFIX}/info/${PORTNAME:S/utils//}.info ${PREFIX}/info/dir
+#post-extract: remove-info-files
+#
+#remove-info-files:
+# @${RM} -f ${WRKSRC}/${PORTNAME:S/utils//}.info*
+#
+#post-patch: patch-makeinfo
+#
+#patch-makeinfo:
+# @${REINPLACE_CMD} -e 's|makeinfo|makeinfo --no-split|g' \
+# ${WRKSRC}/Makefile.in
+#
+#post-install: install-info
+#
+#install-info:
+# @${INSTALL_INFO} ${PREFIX}/info/${PORTNAME:S/utils//}.info ${PREFIX}/info/dir
.include <bsd.port.mk>