aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/diffutils/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/diffutils/Makefile')
-rw-r--r--textproc/diffutils/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/textproc/diffutils/Makefile b/textproc/diffutils/Makefile
new file mode 100644
index 000000000000..feb830ec0999
--- /dev/null
+++ b/textproc/diffutils/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: diffutils
+# Date created: 5 September 2001
+# Whom: Garrett Rooney <rooneg@electricjellyfish.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= diffutils
+PORTVERSION= 2.7
+CATEGORIES= textproc
+MASTER_SITES= ${MASTER_SITE_GNU}
+MASTER_SITE_SUBDIR= diffutils
+
+MAINTAINER= rooneg@electricjellyfish.net
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --program-prefix=g
+
+INSTALL_INFO?= install-info
+
+post-extract: remove-info-files
+
+remove-info-files:
+ @${RM} -f ${WRKSRC}/${PORTNAME:S/utils//}.info*
+
+post-patch: patch-makeinfo
+
+patch-makeinfo:
+ @${PERL} -pi.fbsd -e 's|makeinfo|makeinfo --no-split|g' \
+ ${WRKSRC}/Makefile.in
+
+post-install: install-info
+
+install-info:
+ @${INSTALL_INFO} ${PREFIX}/info/${PORTNAME:S/utils//}.info ${PREFIX}/info/dir
+
+.include <bsd.port.mk>