aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/ekhtml/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/ekhtml/Makefile')
-rw-r--r--textproc/ekhtml/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/textproc/ekhtml/Makefile b/textproc/ekhtml/Makefile
new file mode 100644
index 000000000000..cc1fa13e4de9
--- /dev/null
+++ b/textproc/ekhtml/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: ekhtml
+# Date created: 21 December 2007
+# Whom: Ditesh Shashikant Gathani <ditesh@gathani.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ekhtml
+PORTVERSION= 0.3.2
+CATEGORIES= textproc
+MASTER_SITES= SF
+
+MAINTAINER= ditesh@gathani.org
+COMMENT= El-Kabong is a speedy, yet forgiving, SAX-style HTML parser
+
+USE_AUTOTOOLS= libtool:15
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+USE_LDCONFIG= yes
+
+PLIST_FILES= include/ekhtml.h lib/libekhtml.a \
+ lib/libekhtml.la lib/libekhtml.so \
+ lib/libekhtml.so.0
+
+.include <bsd.port.mk>