aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/enchant/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/enchant/Makefile')
-rw-r--r--textproc/enchant/Makefile38
1 files changed, 16 insertions, 22 deletions
diff --git a/textproc/enchant/Makefile b/textproc/enchant/Makefile
index b5301d92334e..b4f64ad79b05 100644
--- a/textproc/enchant/Makefile
+++ b/textproc/enchant/Makefile
@@ -14,7 +14,8 @@ COMMENT= Dictionary/spellchecking framework
USE_GMAKE= yes
USE_AUTOTOOLS= libtool
USE_LDCONFIG= yes
-USE_GNOME= gnomehack glib20 ltverhack
+USES= pathfix
+USE_GNOME= glib20 ltverhack
USE_PKGCONFIG= build
CONFIGURE_ARGS= --disable-uspell \
--disable-voikko
@@ -25,16 +26,15 @@ LDFLAGS+= -L${LOCALBASE}/lib
MAN1= enchant.1
-OPTIONS= ASPELL "Enable Aspell backend" on \
- HSPELL "Enable Hspell backend" off \
- HUNSPELL "Enable Hunspell backend" off \
- ISPELL "Enable Ispell backend" off \
- ZEMBEREK "Enable zemberek backend (requires DBUS)" off
+OPTIONS_DEFINE= ASPELL HSPELL HUNSPELL ISPELL ZEMBEREK
+HSPELL_DESC= Spell checking via Hspell
+HUNSPELL_DESC= Spell checking via Hunspell
+ZEMBEREK_DESC= Spell checking via Zemberek
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_ASPELL)
-LIB_DEPENDS+= pspell.16:${PORTSDIR}/textproc/aspell
+.if ${PORT_OPTIONS:MASPELL}
+LIB_DEPENDS+= pspell:${PORTSDIR}/textproc/aspell
CONFIGURE_ARGS+=--enable-aspell \
--with-aspell-prefix=${LOCALBASE}
PLIST_SUB+= ASPELL=""
@@ -43,7 +43,7 @@ CONFIGURE_ARGS+=--disable-aspell
PLIST_SUB+= ASPELL="@comment "
.endif
-.if defined(WITH_HSPELL)
+.if ${PORT_OPTIONS:MHSPELL}
BUILD_DEPENDS+= ${LOCALBASE}/lib/libhspell.a:${PORTSDIR}/hebrew/hspell
CONFIGURE_ARGS+=--enable-hspell
PLIST_SUB+= HSPELL=""
@@ -52,8 +52,8 @@ CONFIGURE_ARGS+=--disable-hspell
PLIST_SUB+= HSPELL="@comment "
.endif
-.if defined(WITH_HUNSPELL)
-LIB_DEPENDS+= hunspell-1.3.0:${PORTSDIR}/textproc/hunspell
+.if ${PORT_OPTIONS:MHUNSPELL}
+LIB_DEPENDS+= hunspell-1.3:${PORTSDIR}/textproc/hunspell
CONFIGURE_ARGS+=--enable-myspell
PLIST_SUB+= HUNSPELL=""
.else
@@ -61,7 +61,7 @@ CONFIGURE_ARGS+=--disable-myspell
PLIST_SUB+= HUNSPELL="@comment "
.endif
-.if defined(WITH_ISPELL)
+.if ${PORT_OPTIONS:MISPELL}
RUN_DEPENDS+= ispell:${PORTSDIR}/textproc/ispell
CONFIGURE_ARGS+=--enable-ispell
PLIST_SUB+= ISPELL=""
@@ -70,8 +70,8 @@ CONFIGURE_ARGS+=--disable-ispell
PLIST_SUB+= ISPELL="@comment "
.endif
-.if defined(WITH_ZEMBEREK) && !defined(WITHOUT_DBUS)
-LIB_DEPENDS+= dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib
+.if ${PORT_OPTIONS:MZEMBEREK}
+LIB_DEPENDS+= dbus-glib-1:${PORTSDIR}/devel/dbus-glib
CONFIGURE_ARGS+=--enable-zemberek
PLIST_SUB+= ZEMBEREK=""
.else
@@ -82,11 +82,5 @@ CONFIGURE_ARGS+=--disable-zemberek
post-patch:
@${REINPLACE_CMD} -e 's|MKDIRPROG-mkdir|MKDIRPROG-mkdir -p|g' \
${WRKSRC}/install-sh
-.if ${OSVERSION} < 700042
- @${REINPLACE_CMD} -E -e "s|-Wunsafe-loop-optimizations ||g" \
- -e "s|-Wno-missing-field-initializers ||g" \
- -e "s|-Wno-attributes ||g" \
- ${WRKSRC}/configure
-.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>