aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/enchant/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/enchant/Makefile')
-rw-r--r--textproc/enchant/Makefile39
1 files changed, 22 insertions, 17 deletions
diff --git a/textproc/enchant/Makefile b/textproc/enchant/Makefile
index bce56af02c5c..26fa8623fe69 100644
--- a/textproc/enchant/Makefile
+++ b/textproc/enchant/Makefile
@@ -3,11 +3,11 @@
# Whom: Adam Weinberger <adamw@FreeBSD.org>
#
# $FreeBSD$
+# $MCom: ports-stable/textproc/enchant/Makefile,v 1.1 2006/03/12 02:08:58 mezz Exp $
#
PORTNAME= enchant
-PORTVERSION= 1.2.0
-PORTREVISION= 1
+PORTVERSION= 1.2.3
CATEGORIES= textproc gnome
MASTER_SITES= http://www.abisource.com/downloads/enchant/${PORTVERSION}/
# ${MASTER_SITE_SOURCEFORGE}
@@ -18,10 +18,11 @@ MAINTAINER= gnome@FreeBSD.org
COMMENT= Dictionary/spellchecking framework
USE_GMAKE= yes
-USE_REINPLACE= yes
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:15
INSTALLS_SHLIB= yes
USE_GNOME= gnomehack gnometarget glib20 ltverhack
+CONFIGURE_ARGS= --disable-hspell \
+ --disable-uspell
CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
@@ -29,23 +30,27 @@ MAN1= enchant.1
.ifndef(WITHOUT_ASPELL)
LIB_DEPENDS+= pspell.16:${PORTSDIR}/textproc/aspell
+CONFIGURE_ARGS+=--enable-aspell
PLIST_SUB+= ASPELL=""
.else
+CONFIGURE_ARGS+=--disable-aspell
PLIST_SUB+= ASPELL="@comment "
.endif
.include <bsd.port.pre.mk>
-.if exists(${LOCALBASE}/bin/hspell)
-WITH_HSPELL= yes
-.endif
+#.if exists(${LOCALBASE}/bin/hspell)
+#WITH_HSPELL= yes
+#.endif
-.if defined(WITH_HSPELL)
-BUILD_DEPENDS+= hspell:${PORTSDIR}/hebrew/hspell
-PLIST_SUB+= HSPELL=""
-.else
-PLIST_SUB+= HSPELL="@comment "
-.endif
+#.if defined(WITH_HSPELL)
+#BUILD_DEPENDS+= hspell:${PORTSDIR}/hebrew/hspell
+#CONFIGURE_ARGS+=--enable-hspell
+#PLIST_SUB+= HSPELL=""
+#.else
+#CONFIGURE_ARGS+=--disable-hspell
+#PLIST_SUB+= HSPELL="@comment "
+#.endif
pre-everything::
.if !defined(WITHOUT_ASPELL) || !defined(WITH_HSPELL)
@@ -54,10 +59,10 @@ pre-everything::
@${ECHO_CMD} '===>'
@${ECHO_CMD} '===> Define WITHOUT_ASPELL to disable aspell support'
.endif
-.if !defined(WITH_HSPELL)
- @${ECHO_CMD} '===>'
- @${ECHO_CMD} '===> Define WITH_HSPELL to enable hspell (Hebrew) support'
-.endif
+#.if !defined(WITH_HSPELL)
+# @${ECHO_CMD} '===>'
+# @${ECHO_CMD} '===> Define WITH_HSPELL to enable hspell (Hebrew) support'
+#.endif
.endif
post-patch: