aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/freexl/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/freexl/Makefile')
-rw-r--r--textproc/freexl/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/textproc/freexl/Makefile b/textproc/freexl/Makefile
new file mode 100644
index 000000000000..a5fccb40062f
--- /dev/null
+++ b/textproc/freexl/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: freexl
+# Date created: 19 May 2012
+# Whom: lbartoletti <coder@tuxfamily.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= freexl
+DISTVERSION= 1.0.0b
+#PORTVERSION= 1.0.0b
+CATEGORIES= textproc
+MASTER_SITES= http://www.gaia-gis.it/gaia-sins/
+
+MAINTAINER= coder@tuxfamily.org
+COMMENT= Library to extract valid data from within an Excel (.xls) spreadsheet
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_ICONV= yes
+
+CFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib -liconv
+CONFIGURE_ARGS+=CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+USE_LDCONFIG= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|(libdir)/pkgconfig|(prefix)/libdata/pkgconfig|g' \
+ ${WRKSRC}/Makefile.in
+.include <bsd.port.mk>