aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/gastex/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/gastex/Makefile')
-rw-r--r--textproc/gastex/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/textproc/gastex/Makefile b/textproc/gastex/Makefile
new file mode 100644
index 000000000000..859356c34bd6
--- /dev/null
+++ b/textproc/gastex/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: gastex
+# Date created: Sep 18. 2005
+# Whom: Volker Stolz <vs@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gastex
+PORTVERSION= 2.7
+CATEGORIES= textproc
+MASTER_SITES= http://www.lsv.ens-cachan.fr/~gastin/gastex/
+DISTFILES= gastex.sty gastex.pro ex-gastex.tex
+DIST_SUBDIR= ${PORTNAME}-${PORTVERSION}
+EXTRACT_ONLY= #
+
+MAINTAINER= vs@FreeBSD.org
+COMMENT= Graphs and Automata Simplified in TeX
+
+BUILD_DEPENDS= mktexlsr:${PORTSDIR}/print/teTeX-base
+RUN_DEPENDS= latex:${PORTSDIR}/print/teTeX-base
+
+NO_BUILD= yes
+
+TEXMFDIR?= share/texmf
+GASTEXDIR= ${PREFIX}/${TEXMFDIR}/tex/latex/gastex
+GASDVIDIR= ${PREFIX}/${TEXMFDIR}/dvips/gastex
+
+do-install:
+ @${MKDIR} ${GASTEXDIR}
+ @${MKDIR} ${GASDVIDIR}
+ @${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${_DISTDIR}/gastex.sty ${GASTEXDIR}
+ ${INSTALL_DATA} ${_DISTDIR}/gastex.pro ${GASDVIDIR}
+ ${INSTALL_DATA} ${_DISTDIR}/ex-gastex.tex ${EXAMPLESDIR}
+ mktexlsr
+
+.include <bsd.port.mk>