aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/gsed/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/gsed/Makefile')
-rw-r--r--textproc/gsed/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/textproc/gsed/Makefile b/textproc/gsed/Makefile
new file mode 100644
index 000000000000..c233213ec6a4
--- /dev/null
+++ b/textproc/gsed/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: sed
+# Date created: 12 October 2000
+# Whom: Cyrille Lefevre <clefevre@citeweb.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= sed
+PORTVERSION= 3.02
+CATEGORIES= textproc
+MASTER_SITES= ${MASTER_SITE_GNU}
+MASTER_SITE_SUBDIR= sed
+
+MAINTAINER= ports@FreeBSD.org
+
+GNU_CONFIGURE= yes
+
+# sed's configure seems to be buggy !
+# CONFIGURE_ARGS= --program-prefix=g
+
+MAN1= gsed.1
+
+post-configure:
+ @${PERL} -pi.fbsd -e 's/s,x,x,/s,^,g,/' \
+ ${WRKSRC}/Makefile \
+ ${WRKSRC}/doc/Makefile \
+ ${WRKSRC}/lib/Makefile \
+ ${WRKSRC}/sed/Makefile
+
+post-install: share-examples
+ @install-info ${PREFIX}/info/sed.info ${PREFIX}/info/dir
+
+share-examples:
+ @${MKDIR} ${PREFIX}/share/examples/gsed
+ @${INSTALL_DATA} ${WRKSRC}/dc.sed ${PREFIX}/share/examples/gsed
+
+.include <bsd.port.mk>