aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/hs-libxml
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/hs-libxml')
-rw-r--r--textproc/hs-libxml/Makefile20
-rw-r--r--textproc/hs-libxml/distinfo3
-rw-r--r--textproc/hs-libxml/pkg-descr4
-rw-r--r--textproc/hs-libxml/pkg-plist20
4 files changed, 47 insertions, 0 deletions
diff --git a/textproc/hs-libxml/Makefile b/textproc/hs-libxml/Makefile
new file mode 100644
index 000000000000..456bd51f268e
--- /dev/null
+++ b/textproc/hs-libxml/Makefile
@@ -0,0 +1,20 @@
+# New ports collection makefile for: hs-libxml
+# Date created: May 22, 2010
+# Whom: Gabor Pali <pgj@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libxml
+PORTVERSION= 0.1.1
+CATEGORIES= textproc haskell
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= Binding to libxml2
+
+USE_GNOME= libxml2
+
+CONFIGURE_ARGS+= --extra-include-dirs="${LOCALBASE}/include/libxml2"
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
+.include <bsd.port.mk>
diff --git a/textproc/hs-libxml/distinfo b/textproc/hs-libxml/distinfo
new file mode 100644
index 000000000000..6b9edbf42d0f
--- /dev/null
+++ b/textproc/hs-libxml/distinfo
@@ -0,0 +1,3 @@
+MD5 (libxml-0.1.1.tar.gz) = 417ec538637b313bd4d5ef9545624ab5
+SHA256 (libxml-0.1.1.tar.gz) = d1e92affb41e7abe1c7b692aa24ae47dbcf3636f2753bb85a3469c370d9afb07
+SIZE (libxml-0.1.1.tar.gz) = 3959
diff --git a/textproc/hs-libxml/pkg-descr b/textproc/hs-libxml/pkg-descr
new file mode 100644
index 000000000000..1fbf9c4d4b1e
--- /dev/null
+++ b/textproc/hs-libxml/pkg-descr
@@ -0,0 +1,4 @@
+Minimal binding to libxml2. Additional functions will be added when
+needed.
+
+WWW: http://hackage.haskell.org/package/libxml
diff --git a/textproc/hs-libxml/pkg-plist b/textproc/hs-libxml/pkg-plist
new file mode 100644
index 000000000000..2d7d5e25053a
--- /dev/null
+++ b/textproc/hs-libxml/pkg-plist
@@ -0,0 +1,20 @@
+@comment $FreeBSD$
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Text/XML/LibXML.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Text/XML/LibXML/Internals.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Text/XML/LibXML/Parser.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Text/XML/LibXML/Tree.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Text/XML/LibXML/Types.hi
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/HS%%PORTNAME%%-%%PORTVERSION%%.o
+%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/libHS%%PORTNAME%%-%%PORTVERSION%%.a
+%%LIBDIR_REL%%/register.sh
+%%NOPORTDOCS%%%%DOCSDIR%%/LICENSE
+%%NOPORTDOCS%%@dirrmtry %%DOCSDIR%%
+@dirrm %%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Text/XML/LibXML
+@dirrm %%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Text/XML
+@dirrm %%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Text
+@dirrm %%LIBDIR_REL%%/ghc-%%GHC_VERSION%%
+@dirrm %%LIBDIR_REL%%
+@exec /bin/sh %D/%%LIBDIR_REL%%/register.sh
+@exec /bin/rm -f %D/lib/ghc-%%GHC_VERSION%%/package.conf.old
+@unexec %D/bin/ghc-pkg unregister %%PORTNAME%%-%%PORTVERSION%%
+@unexec /bin/rm -f %D/lib/ghc-%%GHC_VERSION%%/package.conf.old