aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/hs-texmath/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/hs-texmath/Makefile')
-rw-r--r--textproc/hs-texmath/Makefile29
1 files changed, 26 insertions, 3 deletions
diff --git a/textproc/hs-texmath/Makefile b/textproc/hs-texmath/Makefile
index 3fe505d6ed96..a8a31a2dba8f 100644
--- a/textproc/hs-texmath/Makefile
+++ b/textproc/hs-texmath/Makefile
@@ -6,18 +6,41 @@
#
PORTNAME= texmath
-PORTVERSION= 0.2.0.3
+PORTVERSION= 0.3.0.1
CATEGORIES= textproc haskell
MAINTAINER= haskell@FreeBSD.org
COMMENT= Conversion of LaTeX math formulas to MathML for Haskell
CABAL_SETUP= Setup.hs
-USE_HACKAGE= cgi json xml
+USE_HACKAGE= xml utf8-string
-EXECUTABLE= testTeXMathML texmath-cgi
+OPTIONS= CGI "Compile CGI executable" off \
+ TEST "Compile test executable" off
PORTDATA= *
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.options.mk"
+.include <bsd.port.options.mk>
+
+.if defined(WITH_CGI)
+CONFIGURE_ARGS+= --flags="cgi"
+USE_HACKAGE+= cgi json
+EXECUTABLE+= texmath-cgi
+PLIST_SUB+= MAYBE_CGI=""
+.else
+CONFIGURE_ARGS+= --flags="-cgi"
+PLIST_SUB+= MAYBE_CGI="@comment "
+.endif
+
+.if defined(WITH_TEST)
+CONFIGURE_ARGS+= --flags="test"
+EXECUTABLE+= testTeXMathML
+PLIST_SUB+= MAYBE_TEST=""
+.else
+CONFIGURE_ARGS+= --flags="-test"
+PLIST_SUB+= MAYBE_TEST="@comment "
+.endif
+
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>