aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/html2text/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/html2text/Makefile')
-rw-r--r--textproc/html2text/Makefile43
1 files changed, 25 insertions, 18 deletions
diff --git a/textproc/html2text/Makefile b/textproc/html2text/Makefile
index 708bdd926b80..9d73cf199408 100644
--- a/textproc/html2text/Makefile
+++ b/textproc/html2text/Makefile
@@ -6,37 +6,44 @@
#
PORTNAME= html2text
-PORTVERSION= 1.3.2
+PORTVERSION= 1.3.2a
CATEGORIES= textproc
-MASTER_SITES= http://userpage.fu-berlin.de/~mbayer/tools/ \
- ftp://ftp.ibiblio.org/pub/linux/apps/www/converters/
+MASTER_SITES= ${MASTER_SITE_SUNSITE} \
+ http://userpage.fu-berlin.de/~mbayer/tools/
+MASTER_SITE_SUBDIR= apps/www/converters
MAINTAINER= ports@FreeBSD.org
COMMENT= Converts HTML documents into plain text
USE_REINPLACE= yes
-GNU_CONFIGURE= yes
-MANCOMPRESSED= yes
-
-MAN1= html2text.1
-MAN5= html2textrc.5
+HAS_CONFIGURE= yes
+MAKE_ARGS= CXX="${CXX}"
-DOCS= CHANGES COPYING CREDITS KNOWN_BUGS README TODO
-
-.include <bsd.port.pre.mk>
+MANCOMPRESSED= yes
+MAN1= html2text.1
+MAN5= html2textrc.5
+PORTDOCS= CHANGES CREDITS KNOWN_BUGS README TODO
+PLIST_FILES= bin/html2text
post-patch:
@${REINPLACE_CMD} -e '/echo=/s/ -e//' ${WRKSRC}/configure
- @${REINPLACE_CMD} -e '/^DEBUG/s/^/#/; /^CXXFLAGS/s/=/+=/' \
- ${WRKSRC}/Makefile.in ${WRKSRC}/libstd/Makefile.in
+.for file in Makefile.in libstd/Makefile.in
+ @${REINPLACE_CMD} -e '/^DEBUG/s/^/#/; \
+ /^CXXFLAGS/s/=/+=/' ${WRKSRC}/${file}
+.endfor
+.for file in Area.h HTMLControl.h Properties.h format.h
+ @${REINPLACE_CMD} -e 's/<istream>/<iostream>/' ${WRKSRC}/${file}
+.endfor
do-install:
- @${INSTALL_PROGRAM} ${WRKSRC}/html2text ${PREFIX}/bin
- @${INSTALL_MAN} ${WRKSRC}/html2text.1.gz ${MANPREFIX}/man/man1
- @${INSTALL_MAN} ${WRKSRC}/html2textrc.5.gz ${MANPREFIX}/man/man5
+ ${INSTALL_PROGRAM} ${WRKSRC}/html2text ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/html2text.1.gz ${MANPREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/html2textrc.5.gz ${MANPREFIX}/man/man5
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
- @${INSTALL_DATA} ${DOCS:C#^#${WRKSRC}/#g} ${DOCSDIR}
+.for file in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+.endfor
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>