aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/hyphen/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/hyphen/Makefile')
-rw-r--r--textproc/hyphen/Makefile22
1 files changed, 14 insertions, 8 deletions
diff --git a/textproc/hyphen/Makefile b/textproc/hyphen/Makefile
index 9895a1c39dfa..896843449908 100644
--- a/textproc/hyphen/Makefile
+++ b/textproc/hyphen/Makefile
@@ -9,30 +9,36 @@ PORTNAME= hyphen
PORTVERSION= 2.7.1
PORTREVISION= 1
CATEGORIES= textproc
-MASTER_SITES= SF/hunspell/Hyphen/2.7/
+MASTER_SITES= SF/hunspell/Hyphen/${PORTVERSION:R}/
MAINTAINER= office@FreeBSD.org
COMMENT= Library for high quality hyphenation and justification
BUILD_DEPENDS= gawk:${PORTSDIR}/lang/gawk
+GNU_CONFIGURE= yes
USE_GNOME= gnomehack
USE_LDCONFIG= yes
USE_PERL5_BUILD= yes
-GNU_CONFIGURE= yes
+PLIST_FILES= bin/substrings.pl \
+ include/hyphen.h \
+ lib/libhyphen.a \
+ lib/libhyphen.la \
+ lib/libhyphen.so \
+ lib/libhyphen.so.2 \
+ %%DATADIR%%/hyph_en_US.dic
+PLIST_DIRSTRY= %%DATADIR%%
USALIASES= en_AG en_AU en_BS en_BW en_BZ en_CA en_DK en_GB en_GH en_HK \
en_IE en_IN en_JM en_NA en_NZ en_PH en_SG en_TT en_ZA en_ZW
-
.for ALIAS in ${USALIASES}
-PLIST_FILES+= share/hyphen/hyph_${ALIAS}.dic
+PLIST_FILES+= %%DATADIR%%/hyph_${ALIAS}.dic
.endfor
post-install:
- @cd ${DATADIR}; \
- for alias in ${USALIASES}; do \
- ${LN} -s hyph_en_US.dic hyph_$${alias}.dic ; \
- done
+.for ALIAS in ${USALIASES}
+ ${LN} -s hyph_en_US.dic ${DATADIR}/hyph_${ALIAS}.dic
+.endfor
.include <bsd.port.mk>