aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/iiimf-x/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/iiimf-x/Makefile')
-rw-r--r--textproc/iiimf-x/Makefile33
1 files changed, 21 insertions, 12 deletions
diff --git a/textproc/iiimf-x/Makefile b/textproc/iiimf-x/Makefile
index 94a59584e382..7a82a8f54d8f 100644
--- a/textproc/iiimf-x/Makefile
+++ b/textproc/iiimf-x/Makefile
@@ -7,6 +7,7 @@
PORTNAME= x
PORTVERSION= ${IIIMF_VER:S/_/./g:C/-.*//}
+PORTREVISION= 1
CATEGORIES= textproc
MASTER_SITES= http://www.openi18n.org/download/im-sdk/src/
PKGNAMEPREFIX= iiimf-
@@ -24,12 +25,13 @@ IIIMF_VER= r12_1-svn2002
USE_BZIP2= yes
USE_REINPLACE= yes
USE_GMAKE= yes
-USE_GNOME= intltool
USE_XLIB= yes
-WANT_AUTOCONF_VER=253
-WANT_AUTOHEADER_VER=253
-WANT_AUTOMAKE_VER=15
-WANT_LIBTOOL_VER=15
+USE_AUTOCONF_VER= 259
+USE_AUTOHEADER_VER= 259
+USE_AUTOMAKE_VER= 19
+WANT_LIBTOOL_VER= 15
+
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
WRKSRC= ${WRKDIR}/${DISTNAME:S/src-//}/iiimxcf/htt_xbe
PATCH_WRKSRC= ${WRKDIR}/${DISTNAME:S/src-//}
@@ -44,20 +46,27 @@ IGNORE= "It is supported on FreeBSD 5.3 and later"
IGNORE= "${ARCH} is not support."
.endif
-MAKE_ARGS+= LIBTOOL="${LIBTOOL} --tag=CXX"
+CFLAGS+= -I${LOCALBASE}/include -I${X11BASE}/include ${PTHREAD_CFLAGS}
+LDFLAGS+= -L${LOCALBASE}/lib -L${X11BASE}/lib ${PTHREAD_LIBS}
+CONFIGURE_ENV+= LDFLAGS="${LDFLAGS}"
UPDATE_ARGS+= ACLOCAL=${ACLOCAL} AUTOMAKE=${AUTOMAKE} \
AUTOHEADER=${AUTOHEADER} AUTOCONF=${AUTOCONF} \
- LIBTOOL=${LIBTOOL} LIBTOOLIZE=${LIBTOOLIZE}
+ LIBTOOL=${LIBTOOL} LIBTOOLIZE=${LIBTOOLIZE} \
+ ACLOCAL_DIR="-I ${LOCALBASE}/share/aclocal -I ${ACLOCAL_DIR}"
post-patch:
${REINPLACE_CMD} -e "s,/usr/lib/im,${PREFIX}/lib/im,g" \
${WRKSRC}/../../acfiles/im_common.m4
pre-configure:
- (cd ${WRKSRC}/../.. && ${GMAKE} ${UPDATE_ARGS} update-acfiles)
- (cd ${WRKSRC}/../../acfiles/ && ${TOUCH} ltconfig)
-
-do-configure:
- (cd ${WRKSRC} && ./autogen.sh --prefix=${PREFIX})
+ @cd ${WRKSRC}/../.. && ${GMAKE} ${UPDATE_ARGS} update-acfiles
+ @cd ${WRKSRC} && ${SETENV} ${AUTOTOOLS_ENV} ${ACLOCAL} \
+ -I ../../acfiles -I ${LOCALBASE}/share/aclocal -I ${ACLOCAL_DIR}
+ @cd ${WRKSRC} && ${REINPLACE_CMD} \
+ -e "s^\$$ac_aux_dir/ltconfig^${LTCONFIG}^g" \
+ -e "/^ltmain=/!s^\$$ac_aux_dir/ltmain.sh^${LIBTOOLFLAGS} ${LTMAIN}^g" \
+ -e '/^LIBTOOL=/s^\$$(top_builddir)/libtool^${LIBTOOL}^g' \
+ ${LIBTOOLFILES}
+ @cd ${WRKSRC} && ${SETENV} ${AUTOTOOLS_ENV} ${AUTOHEADER}
.include <bsd.port.post.mk>