aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/irstlm/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/irstlm/Makefile')
-rw-r--r--textproc/irstlm/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/textproc/irstlm/Makefile b/textproc/irstlm/Makefile
new file mode 100644
index 000000000000..d802ac3d5f1a
--- /dev/null
+++ b/textproc/irstlm/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: irstlm
+# Date created: 31 May 2010
+# Whom: Dmitry Sivachenko <demon@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= irstlm
+PORTVERSION= 5.40.01
+CATEGORIES= textproc
+MASTER_SITES= http://hlt.fbk.eu/sites/hlt.fbk.eu/files/irstlm/
+
+MAINTAINER= demon@FreeBSD.org
+COMMENT= The IRST Language Modeling Toolkit
+
+USE_ZIP= yes
+GNU_CONFIGURE= yes
+
+do-install:
+.for f in dict ngt compile_lm interpolate_lm prune_lm quantize_lm tlm
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/$f ${PREFIX}/bin/
+.endfor
+ ${INSTALL_DATA} ${WRKSRC}/src/libirstlm.a ${PREFIX}/lib/
+ ${RANLIB} ${PREFIX}/lib/libirstlm.a
+ ${INSTALL_DATA} ${WRKSRC}/src/*.h ${PREFIX}/include/
+
+.include <bsd.port.mk>