aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/jing/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/jing/Makefile')
-rw-r--r--textproc/jing/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/textproc/jing/Makefile b/textproc/jing/Makefile
index f8be3ca9df53..d1fdea397f9c 100644
--- a/textproc/jing/Makefile
+++ b/textproc/jing/Makefile
@@ -10,7 +10,7 @@ PORTVERSION= 2002.02.13
CATEGORIES= textproc
MASTER_SITES= http://www.thaiopensource.com/relaxng/
DISTNAME= ${PORTNAME}
-DISTFILES= ${JAR} jing.html copying.txt
+DISTFILES= ${JARFILE} jing.html copying.txt
DIST_SUBDIR= ${PORTNAME}
EXTRACT_ONLY=
@@ -18,22 +18,22 @@ MAINTAINER= fuyuki@mj.0038.net
JAXP?= crimson # or xalan, saxon
-RUN_DEPENDS= javavm:${PORTSDIR}/java/javavmwrapper
-
.if ${JAXP} == "xalan"
RUN_DEPENDS+= ${LOCALBASE}/xalan-j2.1.0/bin/${JAXP}.jar:${PORTSDIR}/java/xalan-j
.else
RUN_DEPENDS+= ${LOCALBASE}/share/java/classes/${JAXP}.jar:${PORTSDIR}/textproc/${JAXP}
.endif
+USE_JAVA= 1.1+
+NO_BUILD_DEPENDS_JAVA= yes
NO_BUILD= yes
-JAR= ${DISTNAME}.jar
+JARFILE= ${DISTNAME}.jar
JAVALIBDIR= ${PREFIX}/share/java/classes
do-install:
${MKDIR} ${JAVALIBDIR}
- ${INSTALL_DATA} ${DISTDIR}/${DIST_SUBDIR}/${JAR} ${JAVALIBDIR}
+ ${INSTALL_DATA} ${DISTDIR}/${DIST_SUBDIR}/${JARFILE} ${JAVALIBDIR}
post-install:
${MKDIR} ${DOCSDIR}