aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/libmrss-php/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/libmrss-php/Makefile')
-rw-r--r--textproc/libmrss-php/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/textproc/libmrss-php/Makefile b/textproc/libmrss-php/Makefile
new file mode 100644
index 000000000000..efc2ebd53753
--- /dev/null
+++ b/textproc/libmrss-php/Makefile
@@ -0,0 +1,31 @@
+# Created by: Rodrigo Osorio <rodrigo@bebik.net>
+# $FreeBSD$
+
+PORTNAME= libmrss
+PORTVERSION= 0.19.2
+CATEGORIES= textproc
+MASTER_SITES= http://www.autistici.org/bakunin/libmrss/
+PKGNAMESUFFIX= -php
+
+MAINTAINER= rodrigo@bebik.net
+COMMENT= PHP library for parsing, writing, and creating RSS
+
+LIB_DEPENDS= mrss:${PORTSDIR}/textproc/libmrss
+
+GNU_CONFIGURE= yes
+CFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+USE_LDCONFIG= yes
+
+USE_PHP= yes
+USE_PHPIZE= yes
+USE_PHP_BUILD= yes
+USE_AUTOTOOLS+= autoconf:env
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/phpmrss
+
+PLIST_FILES= lib/php/${PHP_EXT_DIR}/mrss.so
+PLIST_DIRSTRY= lib/php/${PHP_EXTDIR} \
+ lib/php
+
+.include <bsd.port.mk>