aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/libroxml/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/libroxml/Makefile')
-rw-r--r--textproc/libroxml/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/textproc/libroxml/Makefile b/textproc/libroxml/Makefile
new file mode 100644
index 000000000000..1b3e3cb2a021
--- /dev/null
+++ b/textproc/libroxml/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: libroxml
+# Date created: 2010-04-16
+# Whom: Hung-Yi Chen <gaod@hychen.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libroxml
+PORTVERSION= 2.0.1
+CATEGORIES= textproc
+MASTER_SITES= GOOGLE_CODE
+DISTNAME= libroxml-${PORTVERSION}
+
+MAINTAINER= gaod@hychen.org
+COMMENT= A minimum, easy-to-use, C implementation for xml file parsing
+
+PROJECTHOST= libroxml
+
+USE_GMAKE= yes
+MAKE_ENV+= DESTDIR=${PREFIX}
+USE_LDCONFIG= yes
+
+MAN1= roxml.1
+
+PLIST_FILES= bin/roxml \
+ lib/libroxml.so \
+ lib/libroxml.so.0 \
+ lib/libroxml.a \
+ include/roxml.h
+
+.include <bsd.port.mk>