aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/libxml2/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/libxml2/Makefile')
-rw-r--r--textproc/libxml2/Makefile33
1 files changed, 29 insertions, 4 deletions
diff --git a/textproc/libxml2/Makefile b/textproc/libxml2/Makefile
index 14d814e9085a..1246d1745513 100644
--- a/textproc/libxml2/Makefile
+++ b/textproc/libxml2/Makefile
@@ -40,12 +40,37 @@ PLIST_SUB+= PYTHON:="@comment "
PKGNAMESUFFIX= -nopython
.endif
-.if !defined(WITHOUT_PYTHON)
-pre-extract:
+.if defined(WITH_SCHEMA)
+CONFIGURE_ARGS+= --with-schemas
+.endif
+
+.if defined(WITH_MEM_DEBUG)
+CONFIGURE_ARGS+= --with-mem-debug
+.endif
+
+.if defined(WITH_XMLLINT_HIST)
+CONFIGURE_ARGS+= --with-history
+.endif
+
+.if defined(WITH_THREADS)
+CONFIGURE_ARGS+= --with-threads
+.endif
+
+.if defined(WITH_THREAD_ALLOC)
+CONFIGURE_ARGS+= --with-thread-alloc
+.endif
+
+pre-everything::
@${ECHO_MSG} ""
- @${ECHO_MSG} "If you don't want Python support, add WITHOUT_PYTHON=yes to command line"
+ @${ECHO_MSG} "libxml2 has the following tunables:"
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} " WITHOUT_PYTHON=yes Turns off Python support"
+ @${ECHO_MSG} " WITH_SCHEMA=yes Turns on XML Schema support"
+ @${ECHO_MSG} " WITH_MEM_DEBUG=yes Turns on memory debugging"
+ @${ECHO_MSG} " WITH_XMLLINT_HIST=yes Turns on history for xmllint"
+ @${ECHO_MSG} " WITH_THREADS=yes Turns on multi-threading support"
+ @${ECHO_MSG} " WITH_THREAD_ALLOC=yes Turns on per-thread memory"
@${ECHO_MSG} ""
-.endif
pre-patch:
@find ${WRKSRC} -name Makefile.in | xargs ${REINPLACE_CMD} -e \