aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/m17n-im-config/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/m17n-im-config/Makefile')
-rw-r--r--textproc/m17n-im-config/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/textproc/m17n-im-config/Makefile b/textproc/m17n-im-config/Makefile
new file mode 100644
index 000000000000..13bda4cb3181
--- /dev/null
+++ b/textproc/m17n-im-config/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: m17n-im-config
+# Date created: 1 October 2008
+# Whom: Nikola Lecic <nikola.lecic@anthesphoria.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= m17n-im-config
+PORTVERSION= 0.9.0
+CATEGORIES= textproc
+MASTER_SITES= http://anthesphoria.net/FreeBSD/ports/distfiles/ \
+ http://www.m17n.org/common/im-config/
+
+MAINTAINER= nikola.lecic@anthesphoria.net
+COMMENT= A GUI for per-user configuration of m17n-lib input methods
+
+LIB_DEPENDS= m17n.3:${PORTSDIR}/devel/m17n-lib
+
+USE_AUTOTOOLS= libtool:15
+USE_GNOME= gtk20 intltool intlhack pkgconfig glib20
+USE_GETTEXT= yes
+USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
+
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|^pkgconfigdir = $${libdir}/pkgconfig|pkgconfigdir = $${prefix}/libdata/pkgconfig|' \
+ ${WRKSRC}/Makefile.in
+
+.include <bsd.port.mk>