aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/mxml/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/mxml/Makefile')
-rw-r--r--textproc/mxml/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/textproc/mxml/Makefile b/textproc/mxml/Makefile
new file mode 100644
index 000000000000..d171eca60a0d
--- /dev/null
+++ b/textproc/mxml/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: mxml
+# Date created: 2007-10-12
+# Whom: Martin Wilke <miwi@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mxml
+PORTVERSION= 2.3
+CATEGORIES= textproc
+MASTER_SITES= ${MASTER_SITE_EASYSW}
+MASTER_SITE_SUBDIR= mxml/2.3
+
+MAINTAINER= miwi@FreeBSD.org
+COMMENT= Small XML parsing library
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_AUTOTOOLS= libtool:15
+USE_GNOME= gnomehack
+
+MAN1= mxmldoc.1
+MAN3= mxml.3
+
+DOCS= *
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${CP} -R ${DOCS:S|^|${WRKSRC}/doc/|} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>