aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/nux/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/nux/Makefile')
-rw-r--r--textproc/nux/Makefile25
1 files changed, 12 insertions, 13 deletions
diff --git a/textproc/nux/Makefile b/textproc/nux/Makefile
index 0128ca297033..dff0f9d8c4bc 100644
--- a/textproc/nux/Makefile
+++ b/textproc/nux/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= nux
-PORTVERSION= 1.0
+PORTVERSION= 1.3
PORTEPOCH= 1
CATEGORIES= textproc java
MASTER_SITES= http://dsd.lbl.gov/nux-download/releases/
@@ -17,7 +17,7 @@ COMMENT= Small open-source XQuery extension of the XOM library
RUN_DEPENDS= ${JAVALIBDIR}/xom.jar:${PORTSDIR}/textproc/xom \
${JAVALIBDIR}/saxon8.jar:${PORTSDIR}/textproc/saxon-devel
-OPTIONS= VALIDATION_TOOL "Install the XML Schema validation tool" on
+OPTIONS= XQUERY_TOOL "Install the XQuery command-line tool" on
USE_JAVA= yes
JAVA_VERSION= 1.4+
@@ -26,14 +26,14 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
.include <bsd.port.pre.mk>
-.if defined(WITH_VALIDATION_TOOL)
+.if defined(WITH_XQUERY_TOOL)
RUN_DEPENDS+= ${JAVALIBDIR}/getopt.jar:${PORTSDIR}/java/java-getopt \
classpath:${PORTSDIR}/java/javavmwrapper
.endif
PLIST_FILES= %%JAVAJARDIR%%/${PORTNAME}.jar
-.if defined(WITH_VALIDATION_TOOL)
-PLIST_FILES+= bin/fire-validate
+.if defined(WITH_XQUERY_TOOL)
+PLIST_FILES+= bin/fire-xquery
.endif
.if !defined(NOPORTDOCS)
PORTDOCS= api changelog.html cvs.html dependencies.html \
@@ -41,8 +41,8 @@ PORTDOCS= api changelog.html cvs.html dependencies.html \
mailing.html readme.html style.css todo.html
.endif
-.if defined(WITH_VALIDATION_TOOL)
-SUB_FILES= fire-validate.sh
+.if defined(WITH_XQUERY_TOOL)
+SUB_FILES= fire-xquery.sh
.endif
do-install:
@@ -50,16 +50,15 @@ do-install:
@${MKDIR} ${JAVAJARDIR}
@${INSTALL_DATA} ${WRKSRC}/lib/${PORTNAME}.jar ${JAVAJARDIR}/
@${ECHO_MSG} " [ DONE ]"
-.if defined(WITH_VALIDATION_TOOL)
- @${ECHO_MSG} -n ">> Installing validation tool as ${PREFIX}/bin/${VALIDATION_TOOL}..."
- @${INSTALL_SCRIPT} ${WRKDIR}/fire-validate.sh ${PREFIX}/bin/fire-validate
+.if defined(WITH_XQUERY_TOOL)
+ @${ECHO_MSG} -n ">> Installing XQuery command-line tool as ${PREFIX}/bin/fire-xquery..."
+ @${INSTALL_SCRIPT} ${WRKDIR}/fire-xquery.sh ${PREFIX}/bin/fire-xquery
@${ECHO_MSG} " [ DONE ]"
.endif
.if !defined(NOPORTDOCS)
@${ECHO_MSG} -n ">> Installing documentation in ${DOCSDIR}..."
- @${MKDIR} ${DOCSDIR}
- @cd ${WRKSRC}/doc/ && ${FIND} ${PORTDOCS} \
- | ${CPIO} -pdmu -R ${SHAREOWN}:${SHAREGRP} ${DOCSDIR} > /dev/null 2>&1
+ @cd ${WRKSRC}/doc/ && ${FIND} ${PORTDOCS} -type d -exec ${MKDIR} ${DOCSDIR}/{} \;
+ @cd ${WRKSRC}/doc/ && ${FIND} ${PORTDOCS} -type f -exec ${INSTALL_DATA} {} ${DOCSDIR}/{} \;
@${ECHO_MSG} " [ DONE ]"
.endif