aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/openvanilla-modules
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/openvanilla-modules')
-rw-r--r--textproc/openvanilla-modules/Makefile4
-rw-r--r--textproc/openvanilla-modules/files/extra-patch-Modules-SharedSource-OVCINInfo.cpp11
2 files changed, 13 insertions, 2 deletions
diff --git a/textproc/openvanilla-modules/Makefile b/textproc/openvanilla-modules/Makefile
index 519390d4ae9d..3fa49b0f30f7 100644
--- a/textproc/openvanilla-modules/Makefile
+++ b/textproc/openvanilla-modules/Makefile
@@ -37,8 +37,8 @@ MAKE_ARGS+= INSTALL_PREFIX=${PREFIX} OV_INCLUDE=${LOCALBASE}/include
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 800501
-BROKEN= does not build
+.if (${OSVERSION} >= 800501)
+EXTRA_PATCHES+= ${FILESDIR}/extra-patch-Modules-SharedSource-OVCINInfo.cpp
.endif
.if !defined(WITHOUT_OVIMArray)
diff --git a/textproc/openvanilla-modules/files/extra-patch-Modules-SharedSource-OVCINInfo.cpp b/textproc/openvanilla-modules/files/extra-patch-Modules-SharedSource-OVCINInfo.cpp
new file mode 100644
index 000000000000..aa8981d4899e
--- /dev/null
+++ b/textproc/openvanilla-modules/files/extra-patch-Modules-SharedSource-OVCINInfo.cpp
@@ -0,0 +1,11 @@
+--- Modules/SharedSource/OVCINInfo.cpp.orig 2012-05-06 21:47:52.000000000 +0800
++++ Modules/SharedSource/OVCINInfo.cpp 2012-05-06 22:02:40.000000000 +0800
+@@ -67,7 +67,7 @@
+ }
+
+ #ifndef WIN32
+- #ifdef __linux__
++ #if defined (__linux__) || defined (__FreeBSD__)
+ int CLFileSelect(const struct dirent *entry)
+ #else
+ int CLFileSelect(struct dirent *entry) \ No newline at end of file