aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/p5-CAM-PDF/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/p5-CAM-PDF/Makefile')
-rw-r--r--textproc/p5-CAM-PDF/Makefile21
1 files changed, 2 insertions, 19 deletions
diff --git a/textproc/p5-CAM-PDF/Makefile b/textproc/p5-CAM-PDF/Makefile
index 6f248bb502a3..c85f5227fc23 100644
--- a/textproc/p5-CAM-PDF/Makefile
+++ b/textproc/p5-CAM-PDF/Makefile
@@ -22,30 +22,13 @@ TEST_DEPENDS= p5-Test-Memory-Cycle>=1.02:${PORTSDIR}/devel/p5-Test-Memory-Cycle
USES= perl5
USE_PERL5= configure
-NO_STAGE= yes
-
-MAN1= appendpdf.pl.1 changepagestring.pl.1 changepdfstring.pl.1 \
- changerefkeys.pl.1 crunchjpgs.pl.1 deillustrate.pl.1 \
- deletepdfpage.pl.1 extractallimages.pl.1 extractjpgs.pl.1 \
- fillpdffields.pl.1 getpdffontobject.pl.1 getpdfpage.pl.1 \
- getpdfpageobject.pl.1 getpdftext.pl.1 listfonts.pl.1 \
- listimages.pl.1 listpdffields.pl.1 pdfinfo.pl.1 readpdf.pl.1 \
- renderpdf.pl.1 replacepdfobj.pl.1 revertpdf.pl.1 \
- rewritepdf.pl.1 setpdfbackground.pl.1 setpdfpage.pl.1 \
- stamppdf.pl.1 uninlinepdfimages.pl.1
-
-MAN3= CAM::PDF.3 CAM::PDF::Content.3 CAM::PDF::Decrypt.3 \
- CAM::PDF::GS.3 CAM::PDF::GS::NoText.3 CAM::PDF::Node.3 \
- CAM::PDF::PageText.3 CAM::PDF::Renderer::Dump.3 \
- CAM::PDF::Renderer::Images.3 CAM::PDF::Renderer::Text.3 \
- CAM::PDF::Renderer::TextFB.3
.if !defined(NOPORTDOCS)
PORTDOCS= CHANGES README
post-install:
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
@${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
.endif