aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/p5-POSIX-Regex/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/p5-POSIX-Regex/Makefile')
-rw-r--r--textproc/p5-POSIX-Regex/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/textproc/p5-POSIX-Regex/Makefile b/textproc/p5-POSIX-Regex/Makefile
new file mode 100644
index 000000000000..49a1ba235b3c
--- /dev/null
+++ b/textproc/p5-POSIX-Regex/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: p5-POSIX-Regex
+# Date created: 2006-08-19
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= POSIX-Regex
+PORTVERSION= 0.89
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= POSIX
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= OO interface for the gnu regex engine
+
+PERL_CONFIGURE= yes
+USE_GCC= 3.2+
+
+MAN3= POSIX::Regex.3
+
+post-patch:
+ ${PERL} -pi -e 's/REG_NOERROR/0/g' ${WRKSRC}/Regex.xs
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500703
+BUILD_DEPENDS+= ${SITE_PERL}/ExtUtils/Constant.pm:${PORTSDIR}/devel/p5-ExtUtils-Constant
+.endif
+
+.if ${PERL_LEVEL} < 500601
+IGNORE= requires perl 5.6.x or later. Install lang/perl5 then try again
+.endif
+
+.include <bsd.port.post.mk>