aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/p5-PerlPoint-Package/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/p5-PerlPoint-Package/Makefile')
-rw-r--r--textproc/p5-PerlPoint-Package/Makefile44
1 files changed, 44 insertions, 0 deletions
diff --git a/textproc/p5-PerlPoint-Package/Makefile b/textproc/p5-PerlPoint-Package/Makefile
new file mode 100644
index 000000000000..316d7fa38edd
--- /dev/null
+++ b/textproc/p5-PerlPoint-Package/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: p5-PerlPoint-Package
+# Date created: 8 Jun 2004
+# Whom: mat
+#
+# $FreeBSD$
+#
+
+PORTNAME= PerlPoint-Package
+PORTVERSION= 0.39
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= PerlPoint
+PKGNAMEPREFIX= p5-
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= mat@FreeBSD.org
+COMMENT= PerlPoint is both a presentation and a documentation toolset
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Digest/SHA1.pm:${PORTSDIR}/security/p5-Digest-SHA1
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= YES
+
+MAN1= pp2sdf.1
+MAN3= PerlPoint::Anchors.3 \
+ PerlPoint::Backend.3 \
+ PerlPoint::Constants.3 \
+ PerlPoint::Parser.3 \
+ PerlPoint::Tags.3 \
+ PerlPoint::Tags::Basic.3 \
+ PerlPoint::Tags::CPPP.3 \
+ PerlPoint::Tags::SDF.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/devel/p5-Storable
+.if ${PERL_LEVEL} < 500600
+BUILD_DEPENDS+= ${SITE_PERL}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec \
+ ${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp
+.endif
+.endif
+
+.include <bsd.port.post.mk>