aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/p5-Pod-ProjectDocs/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/p5-Pod-ProjectDocs/Makefile')
-rw-r--r--textproc/p5-Pod-ProjectDocs/Makefile38
1 files changed, 38 insertions, 0 deletions
diff --git a/textproc/p5-Pod-ProjectDocs/Makefile b/textproc/p5-Pod-ProjectDocs/Makefile
new file mode 100644
index 000000000000..821973b3a8f5
--- /dev/null
+++ b/textproc/p5-Pod-ProjectDocs/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: Pod-ProjectDocs
+# Date created: 31 August 2005
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Pod-ProjectDocs
+PORTVERSION= 0.13
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Pod
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skv@FreeBSD.org
+COMMENT= Generates CPAN like pod pages
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/File/Spec.pm:${PORTSDIR}/devel/p5-PathTools \
+ ${SITE_PERL}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64 \
+ ${SITE_PERL}/Pod/Parser.pm:${PORTSDIR}/textproc/p5-Pod-Parser \
+ ${SITE_PERL}/Class/Accessor/Fast.pm:${PORTSDIR}/devel/p5-Class-Accessor \
+ ${SITE_PERL}/Class/Data/Inheritable.pm:${PORTSDIR}/devel/p5-Class-Data-Inheritable \
+ ${SITE_PERL}/${PERL_ARCH}/Template.pm:${PORTSDIR}/www/p5-Template-Toolkit \
+ ${SITE_PERL}/${PERL_ARCH}/Readonly.pm:${PORTSDIR}/devel/p5-Readonly
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN1= pod2projdocs.1
+MAN3= Pod::ProjectDocs.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+IGNORE= Perl 5.8 or newer required. Install lang/perl5.8 and try again.
+.endif
+
+.include <bsd.port.post.mk>