aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/p5-SGML-Parser-OpenSP/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/p5-SGML-Parser-OpenSP/Makefile')
-rw-r--r--textproc/p5-SGML-Parser-OpenSP/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/textproc/p5-SGML-Parser-OpenSP/Makefile b/textproc/p5-SGML-Parser-OpenSP/Makefile
index 606c2df9a632..a926ae8e421c 100644
--- a/textproc/p5-SGML-Parser-OpenSP/Makefile
+++ b/textproc/p5-SGML-Parser-OpenSP/Makefile
@@ -7,7 +7,7 @@
PORTNAME= SGML-Parser-OpenSP
PORTVERSION= 0.994
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= textproc perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -16,14 +16,19 @@ MAINTAINER= cyberbotx@cyberbotx.com
COMMENT= Parse SGML documents using OpenSP
BUILD_DEPENDS= onsgmls:${PORTSDIR}/textproc/opensp \
- p5-Class-Accessor>=0:${PORTSDIR}/devel/p5-Class-Accessor
+ p5-Class-Accessor>=0:${PORTSDIR}/devel/p5-Class-Accessor \
+ p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception
RUN_DEPENDS= ${BUILD_DEPENDS}
USE_DOS2UNIX= yes
PERL_CONFIGURE= yes
CC= ${CXX}
-CONFIGURE_ARGS+="INC=-I${LOCALBASE}/include -I${LOCALBASE}/lib"
+CONFIGURE_ARGS+="INC=-I${LOCALBASE}/include"
MAN3= SGML::Parser::OpenSP.3 SGML::Parser::OpenSP::Tools.3
+post-patch:
+ (cd ${WRKSRC} ; \
+ ${REINPLACE_CMD} "s|%%LOCALBASE%%|${LOCALBASE}|g" Makefile.PL )
+
.include <bsd.port.mk>