aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/p5-XML-Atom-Syndication/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/p5-XML-Atom-Syndication/Makefile')
-rw-r--r--textproc/p5-XML-Atom-Syndication/Makefile12
1 files changed, 4 insertions, 8 deletions
diff --git a/textproc/p5-XML-Atom-Syndication/Makefile b/textproc/p5-XML-Atom-Syndication/Makefile
index 9d63872fd10a..cff32d77bfc9 100644
--- a/textproc/p5-XML-Atom-Syndication/Makefile
+++ b/textproc/p5-XML-Atom-Syndication/Makefile
@@ -6,6 +6,7 @@
PORTNAME= XML-Atom-Syndication
PORTVERSION= 0.94.2
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= textproc perl5
MASTER_SITES= CPAN
@@ -15,12 +16,10 @@ DISTNAME= ${PORTNAME}-${PORTVERSION:R}${PORTVERSION:E}
MAINTAINER= perl@FreeBSD.org
COMMENT= Simple lightweight client for consuming Atom syndication feeds
-RUN_DEPENDS= ${SITE_PERL}/XML/Elemental.pm:${PORTSDIR}/textproc/p5-XML-Elemental \
- ${SITE_PERL}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64 \
- ${SITE_PERL}/Class/ErrorHandler.pm:${PORTSDIR}/devel/p5-Class-ErrorHandler \
- ${SITE_PERL}/XML/Writer.pm:${PORTSDIR}/textproc/p5-XML-Writer
+RUN_DEPENDS= p5-Class-ErrorHandler>=0:${PORTSDIR}/devel/p5-Class-ErrorHandler \
+ p5-XML-Elemental>=2:${PORTSDIR}/textproc/p5-XML-Elemental \
+ p5-XML-Writer>=0.6:${PORTSDIR}/textproc/p5-XML-Writer
BUILD_DEPENDS= ${RUN_DEPENDS}
-BUILD_DEPENDS+= ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
PERL_CONFIGURE= yes
@@ -37,7 +36,4 @@ MAN3= XML::Atom::Syndication.3 \
XML::Atom::Syndication::Text.3 \
XML::Atom::Syndication::Writer.3
-post-patch:
- ${FIND} ${WRKSRC} -name '._*' -delete
-
.include <bsd.port.mk>