aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/p5-XML-Compile/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/p5-XML-Compile/Makefile')
-rw-r--r--textproc/p5-XML-Compile/Makefile12
1 files changed, 10 insertions, 2 deletions
diff --git a/textproc/p5-XML-Compile/Makefile b/textproc/p5-XML-Compile/Makefile
index 251985e04926..ae4f0b69b8e1 100644
--- a/textproc/p5-XML-Compile/Makefile
+++ b/textproc/p5-XML-Compile/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= XML-Compile
-PORTVERSION= 0.12
+PORTVERSION= 0.14
CATEGORIES= textproc perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= XML
@@ -16,8 +16,10 @@ MAINTAINER= tjs@cdpa.nsysu.edu.tw
COMMENT= Compilation based XML processing
RUN_DEPENDS= p5-XML-LibXML>=1.61:${PORTSDIR}/textproc/p5-XML-LibXML \
+ p5-Regexp-Common>0:${PORTSDIR}/textproc/p5-Regexp-Common \
p5-Math-BigInt>=1.77:${PORTSDIR}/math/p5-Math-BigInt
BUILD_DEPENDS= ${RUN_DEPENDS}
+BUILD_DEPENDS+= ${SITE_PERL}/Test/Deep.pm:${PORTSDIR}/devel/p5-Test-Deep
PERL_CONFIGURE= yes
@@ -32,4 +34,10 @@ MAN3= XML::Compile.3 XML::Compile::Schema.3 \
XML::Compile::Schema::XmlReader.3 \
XML::Compile::Schema::XmlWriter.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+IGNORE= requires Perl 5.8 or above. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>