aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/p5-XML-DOM-XPath/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/p5-XML-DOM-XPath/Makefile')
-rw-r--r--textproc/p5-XML-DOM-XPath/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/textproc/p5-XML-DOM-XPath/Makefile b/textproc/p5-XML-DOM-XPath/Makefile
new file mode 100644
index 000000000000..8a8b45c843b6
--- /dev/null
+++ b/textproc/p5-XML-DOM-XPath/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: textproc/p5-XML-DOM-XPath
+# Date created: 8 September 2005
+# Whom: Mauricio Herrera Cuadra <mauricio@arareko.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= XML-DOM-XPath
+PORTVERSION= 0.09
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= XML
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= mauricio@arareko.net
+COMMENT= Adds XPath support to XML::DOM, using XML::XPath engine
+
+BUILD_DEPENDS= ${SITE_PERL}/XML/DOM.pm:${PORTSDIR}/textproc/p5-XML-DOM \
+ ${SITE_PERL}/XML/XPath.pm:${PORTSDIR}/textproc/p5-XML-XPath
+
+PERL_CONFIGURE= yes
+
+MAN3= XML::DOM::XPath.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires at least perl5.6 to build
+.endif
+
+.include <bsd.port.post.mk>