aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/p5-XML-DifferenceMarkup/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/p5-XML-DifferenceMarkup/Makefile')
-rw-r--r--textproc/p5-XML-DifferenceMarkup/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/textproc/p5-XML-DifferenceMarkup/Makefile b/textproc/p5-XML-DifferenceMarkup/Makefile
new file mode 100644
index 000000000000..c3463d1d89e4
--- /dev/null
+++ b/textproc/p5-XML-DifferenceMarkup/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: XML-DifferenceMarkup
+# Date created: 18 January 2004
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= XML-DifferenceMarkup
+PORTVERSION= 0.09
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= XML
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skv@FreeBSD.org
+COMMENT= This module implements an XML diff producing XML output
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/XML/LibXML.pm:${PORTSDIR}/textproc/p5-XML-LibXML \
+ ${SITE_PERL}/Algorithm/Diff.pm:${PORTSDIR}/devel/p5-Algorithm-Diff
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= XML::DifferenceMarkup.3
+
+.include <bsd.port.mk>