aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/p5-XML-Xerces/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/p5-XML-Xerces/Makefile')
-rw-r--r--textproc/p5-XML-Xerces/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/textproc/p5-XML-Xerces/Makefile b/textproc/p5-XML-Xerces/Makefile
new file mode 100644
index 000000000000..8924913b6158
--- /dev/null
+++ b/textproc/p5-XML-Xerces/Makefile
@@ -0,0 +1,30 @@
+# ex:ts=8
+# Ports collection makefile for: p5-XML-Xerces
+# Date created: Jan 19, 2004
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= XML-Xerces
+PORTVERSION= 2.3.0.4
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= XML
+PKGNAMEPREFIX= p5-
+DISTNAME= ${PORTNAME}-${PORTVERSION:R}-${PORTVERSION:E}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= The Perl API to the Apache Xerces XML parser
+
+LIB_DEPENDS= xerces-c.23:${PORTSDIR}/textproc/xerces-c2
+
+PERL_CONFIGURE= yes
+CONFIGURE_ENV= XERCES_INCLUDE=${LOCALBASE}/include \
+ XERCES_LIB=${LOCALBASE}/lib
+USE_GMAKE= yes
+
+post-patch:
+ @${PERL} -pi -e "s|-lpthread|${PTHREAD_LIBS}|" ${WRKSRC}/Makefile.PL
+
+.include <bsd.port.mk>