aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/py-dsv
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/py-dsv')
-rw-r--r--textproc/py-dsv/Makefile21
-rw-r--r--textproc/py-dsv/pkg-descr17
2 files changed, 15 insertions, 23 deletions
diff --git a/textproc/py-dsv/Makefile b/textproc/py-dsv/Makefile
index ed2885d37969..0678cb6a6635 100644
--- a/textproc/py-dsv/Makefile
+++ b/textproc/py-dsv/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: py-csv
-# Date created: 17 January 2002
-# Whom: Johann Visagie <wjv@FreeBSD.org>
-#
+# Created by: Johann Visagie <wjv@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= dsv
PORTVERSION= 1.4.1
@@ -13,23 +9,20 @@ PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
DISTNAME= ${PORTNAME:U}-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
-COMMENT= A Python module to parse or write delimeter-separated (e.g. CSV) files
+COMMENT= Python module to parse or write delimeter-separated (e.g. CSV) files
-.if defined(WITH_GUI)
-USE_WX= 2.4
-WX_COMPS= python
-.endif
-
-USE_PYTHON= yes
+USE_PYTHON= -2.7
USE_PYDISTUTILS= yes
PYDISTUTILS_PKGNAME= DSV
DSV_BASEDIR= ${PYTHONPREFIX_SITELIBDIR}/DSV
+.include <bsd.port.options.mk>
+
post-install:
@${PRINTF} '#!/bin/sh\n${PYTHON_CMD} ${DSV_BASEDIR}/DSV.py "$$@"\n' \
>${WRKDIR}/DSV.sh
- @ ${INSTALL_SCRIPT} ${WRKDIR}/DSV.sh ${PREFIX}/bin/DSV
-.if !defined(NOPORTDOCS)
+ @${INSTALL_SCRIPT} ${WRKDIR}/DSV.sh ${PREFIX}/bin/DSV
+.if ${PORT_OPTIONS:MDOCS}
@ ${MKDIR} ${DOCSDIR}
@ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
.endif
diff --git a/textproc/py-dsv/pkg-descr b/textproc/py-dsv/pkg-descr
index 29e04f5fbd55..ad3730c25df6 100644
--- a/textproc/py-dsv/pkg-descr
+++ b/textproc/py-dsv/pkg-descr
@@ -4,15 +4,14 @@ Paraphrasing the website:
separated values) files. DSV is a generalization of CSV (comma separated
values). CSV is a common file format used by many programs to import and
export data.
-
+
Features:
- - Pure Python
- - Optional wxPython GUI
- - Optional heuristics for determining file format
- - Handles embedded quotes, delimiters and newlines
- - Customizable error handling
- - Simple to use
+ - Pure Python
+ - Optional wxPython GUI
+ - Optional heuristics for determining file format
+ - Handles embedded quotes, delimiters and newlines
+ - Customizable error handling
+ - Simple to use
- Portable
-Author: Cliff Wells <clifford.wells@attbi.com>
-WWW: http://python-dsv.sourceforge.net/
+WWW: http://python-dsv.sourceforge.net/