aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/py-hunspell/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/py-hunspell/Makefile')
-rw-r--r--textproc/py-hunspell/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/textproc/py-hunspell/Makefile b/textproc/py-hunspell/Makefile
new file mode 100644
index 000000000000..0bd14252ac17
--- /dev/null
+++ b/textproc/py-hunspell/Makefile
@@ -0,0 +1,30 @@
+# Created by: Thierry Thomas <thierry@pompo.net>
+# $FreeBSD$
+
+PORTNAME= hunspell
+PORTVERSION= 0.4.1
+PORTREVISION= 1
+CATEGORIES= textproc devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= thierry@FreeBSD.org
+COMMENT= Python module for the Hunspell spellchecker engine
+
+LICENSE= LGPL3
+
+LIB_DEPENDS= libhunspell-${HSPLVER}.so:textproc/hunspell
+
+USES?= python
+USES+= localbase
+USE_PYTHON= distutils
+
+HSPLVER= 1.6
+PLIST_FILES= %%PYTHON_SITELIBDIR%%/hunspell.so
+
+pre-configure:
+ ${REINPLACE_CMD} -e "s|/usr/include|${LOCALBASE}/include|" \
+ -e "s|= \['hunspell|= ['hunspell-${HSPLVER}|" \
+ ${WRKSRC}/${PYSETUP}
+
+.include <bsd.port.mk>