aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/py-qrcode/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/py-qrcode/Makefile')
-rw-r--r--textproc/py-qrcode/Makefile21
1 files changed, 21 insertions, 0 deletions
diff --git a/textproc/py-qrcode/Makefile b/textproc/py-qrcode/Makefile
new file mode 100644
index 000000000000..2494aa326845
--- /dev/null
+++ b/textproc/py-qrcode/Makefile
@@ -0,0 +1,21 @@
+# Created by: Neil Booth
+# $FreeBSD$
+
+PORTNAME= qrcode
+PORTVERSION= 5.1
+CATEGORIES= textproc python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= kyuupichan@gmail.com
+COMMENT= QR Code image generator
+
+LICENSE= BSD3CLAUSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>=1.8:${PORTSDIR}/devel/py-six \
+ ${PYTHON_PKGNAMEPREFIX}pillow>=2.6:${PORTSDIR}/graphics/py-pillow
+
+USES= python
+USE_PYTHON= autoplist distutils
+
+.include <bsd.port.mk>