aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/py-xml/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/py-xml/Makefile')
-rw-r--r--textproc/py-xml/Makefile46
1 files changed, 37 insertions, 9 deletions
diff --git a/textproc/py-xml/Makefile b/textproc/py-xml/Makefile
index 8bb56e08f31e..d75e25dbabf2 100644
--- a/textproc/py-xml/Makefile
+++ b/textproc/py-xml/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= xml
-PORTVERSION= 0.8.3
+PORTVERSION= 0.8.4
CATEGORIES= textproc python
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= pyxml
@@ -14,22 +14,50 @@ PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
DISTNAME= PyXML-${PORTVERSION}
MAINTAINER= mike@skew.org
-COMMENT= The Python XML package, including parser, SAX, DOM, and Expat
+COMMENT= PyXML: Python XML library enhancements
-USE_PYTHON= yes
+USE_PYTHON= 2.1+
USE_PYDISTUTILS= yes
.include <bsd.port.pre.mk>
-CPIO= cpio --quiet -pdum -R
+CPIOARGS= --quiet -pdum -R
DOCSDIR= ${PREFIX}/share/doc/${PKGNAMEPREFIX}${PORTNAME}
EXAMPLESDIR= ${PREFIX}/share/examples/${PKGNAMEPREFIX}${PORTNAME}
PLIST_SUB+= PACKAGE_DIR=_xmlplus
+
+# PyXML's XPath support for minidom (xml.xpath) is functional and is
+# installed by default, unless WITHOUT_XPATH is defined.
+#
+# PyXML's XSLT support for minidom (xml.xslt) is experimental, and may
+# render PyXML incompatible with modern versions of 4Suite. Therefore,
+# this port will not install it by default, unless WITH_XSLT is defined.
+# These defaults are the same as when PyXML is installed independently.
+#
+# WITHOUT_XPATH is ignored if WITH_XSLT is defined.
+#
+# There are no mature XSLT processors that can operate directly on
+# minidom documents, but such documents can be converted to formats
+# that are supported. 4Suite, for example, can convert a DOM directly
+# to a Domlette, and other processors can make use of the serialized
+# form of the document.
+#
+.if defined(WITH_XSLT)
PYDISTUTILS_BUILDARGS+= --with-xslt
PYDISTUTILS_INSTALLARGS+= --with-xslt
-
-pre-install:
- @ ${SH} ${PKGREQ} INSTALL
+PLIST_SUB+= XPATH=""
+PLIST_SUB+= XSLT=""
+.elif defined(WITHOUT_XPATH)
+PYDISTUTILS_BUILDARGS+= --without-xpath --without-xslt
+PYDISTUTILS_INSTALLARGS+= --without-xpath --without-xslt
+PLIST_SUB+= XPATH="@comment "
+PLIST_SUB+= XSLT="@comment "
+.else
+PYDISTUTILS_BUILDARGS+= --with-xpath --without-xslt
+PYDISTUTILS_INSTALLARGS+= --with-xpath --without-xslt
+PLIST_SUB+= XPATH=""
+PLIST_SUB+= XSLT="@comment "
+.endif
post-install:
.if !defined(NOPORTDOCS)
@@ -38,10 +66,10 @@ post-install:
@ ${INSTALL_DATA} ${WRKSRC}/${docfile} ${DOCSDIR}
.endfor
@ cd ${WRKSRC}/doc && ${FIND} * \
- | ${CPIO} ${SHAREOWN}:${SHAREGRP} ${DOCSDIR}
+ | ${CPIO} ${CPIOARGS} ${SHAREOWN}:${SHAREGRP} ${DOCSDIR}
@ ${MKDIR} ${EXAMPLESDIR}
@ cd ${WRKSRC} && ${FIND} demo test \
- | ${CPIO} ${SHAREOWN}:${SHAREGRP} ${EXAMPLESDIR}
+ | ${CPIO} ${CPIOARGS} ${SHAREOWN}:${SHAREGRP} ${EXAMPLESDIR}
.endif
.include <bsd.port.post.mk>