aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/qt4-xml/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/qt4-xml/Makefile')
-rw-r--r--textproc/qt4-xml/Makefile8
1 files changed, 3 insertions, 5 deletions
diff --git a/textproc/qt4-xml/Makefile b/textproc/qt4-xml/Makefile
index 9aacf23f96c7..3c2fe41250ee 100644
--- a/textproc/qt4-xml/Makefile
+++ b/textproc/qt4-xml/Makefile
@@ -19,7 +19,7 @@ MAINTAINER= kde@FreeBSD.org
COMMENT= Qt XML library
USE_QT_VER= 4
-QT_COMPONENTS= qmake moc corelib
+QT_COMPONENTS= qmake_build moc_build corelib
QT_NONSTANDARD= yes
QT_DIST= yes
@@ -45,8 +45,6 @@ EXTRACT_AFTER_ARGS=| ${TAR} -xf - \
WRKSRC= ${WRKDIR}/${DISTNAME}/src/${PORTNAME}
CONFIGURE_WRKSRC=${WRKSRC}/../../
-.include <bsd.port.pre.mk>
-
pre-configure:
${CP} ${.CURDIR}/../../devel/qt4/files/configure ${CONFIGURE_WRKSRC}
${REINPLACE_CMD} -e 's|target.path.*|target.path=${PREFIX}/lib|g' \
@@ -59,10 +57,10 @@ pre-configure:
post-configure:
${REINPLACE_CMD} -e 's|${PREFIX}/lib/pkgconfig|${PREFIX}/libdata/pkgconfig|g' \
- -e 's|.*$$(QMAKE).*||g' -e 's|(test -z.*||g' ${WRKSRC}/Makefile
+ -e 's|.*$$(QMAKE).*||g' ${WRKSRC}/Makefile
${REINPLACE_CMD} -E -e 's|-L.[^[:space:]]*qt-x11-opensource.[^[:space:]]*lib||g' \
-E -e 's|(.*location=).*moc|\1${PREFIX}/bin/moc-qt4|g' \
-E -e 's|(.*location=).*uic|\1${PREFIX}/bin/uic-qt4|g' \
${WRKSRC}/../../lib/pkgconfig/*Qt*
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>