aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/s5/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/s5/Makefile')
-rw-r--r--textproc/s5/Makefile18
1 files changed, 11 insertions, 7 deletions
diff --git a/textproc/s5/Makefile b/textproc/s5/Makefile
index 047c6e2c63b2..1d382dec5502 100644
--- a/textproc/s5/Makefile
+++ b/textproc/s5/Makefile
@@ -7,7 +7,7 @@
PORTNAME= s5
PORTVERSION= 1.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= textproc
MASTER_SITES= http://meyerweb.com/eric/tools/s5/v/${PORTVERSION}/
DISTNAME= ${PORTNAME}-${PORTVERSION:S/.//g}
@@ -18,24 +18,28 @@ COMMENT= A simple HTML-based presentation system
BUILD_DEPENDS= unzip:${PORTSDIR}/archivers/unzip
USE_DOS2UNIX= yes
+DOS2UNIX_REGEX= .*\.(css|htc|html|js|txt)
USE_ZIP= yes
WRKSRC= ${WRKDIR}
NO_BUILD= yes
+MAN1= s5.1
+MANCOMPRESSED= no
+
S5_DIR= ${PREFIX}/share/${PORTNAME}
S5_SUBDIRS= pix primer s5-blank ui
post-extract:
cd ${WRKSRC} && ${UNZIP_CMD} s5-blank.zip
- ${SED} -e "s,/usr/local,${PREFIX}," ${FILESDIR}/s5-blank.sh > ${WRKDIR}/s5-blank.sh
+ ${SED} -e "s,/usr/local,${PREFIX}," ${FILESDIR}/s5.sh > ${WRKDIR}/s5
+ ${SED} -e "s,/usr/local,${PREFIX}," ${FILESDIR}/s5.1 > ${WRKDIR}/s5.1
${FIND} ${WRKDIR} -type f -name .DS_Store -delete
do-install:
${MKDIR} ${S5_DIR}
- ${CP} ${WRKDIR}/*.html ${S5_DIR}/
-.for i in ${S5_SUBDIRS}
- ${CP} -Rp ${WRKDIR}/$i/ ${S5_DIR}/$i/
-.endfor
- ${INSTALL_SCRIPT} ${WRKDIR}/s5-blank.sh ${PREFIX}/bin/s5-blank
+ (cd ${WRKDIR} && \
+ ${COPYTREE_SHARE} "*.html ${S5_SUBDIRS}" ${S5_DIR})
+ ${INSTALL_SCRIPT} ${WRKDIR}/s5 ${PREFIX}/bin/s5
+ ${INSTALL_DATA} ${WRKDIR}/s5.1 ${PREFIX}/man/man1/s5.1
.include <bsd.port.mk>