aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/ssddiff/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/ssddiff/Makefile')
-rw-r--r--textproc/ssddiff/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/textproc/ssddiff/Makefile b/textproc/ssddiff/Makefile
new file mode 100644
index 000000000000..1fea2b072b48
--- /dev/null
+++ b/textproc/ssddiff/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: SSDDiff
+# Date created: 11 Apr 2006
+# Whom: Alexey Dokuchaev <danfe@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ssddiff
+PORTVERSION= 0.2
+CATEGORIES= textproc
+MASTER_SITES= http://alioth.debian.org/download.php/1469/
+
+MAINTAINER= danfe@FreeBSD.org
+COMMENT= A diff application for semistructured data such as XML files
+
+USE_AUTOTOOLS= automake:14
+USE_BZIP2= yes
+USE_GCC= 3.4+
+USE_GNOME= libxml2
+MAKE_ARGS= CXX="${CXX}" CXXFLAGS="${CXXFLAGS}" \
+ CPPFLAGS="-I${LOCALBASE}/include \
+ -I${LOCALBASE}/include/libxml2"
+PLIST_FILES= bin/xmldiff
+
+post-extract:
+.for f in config.guess config.sub install-sh missing mkinstalldirs
+ @${LN} -sf ${LOCALBASE}/share/automake14/${f} ${WRKSRC}/${f}
+.endfor
+
+.include <bsd.port.mk>