aboutsummaryrefslogtreecommitdiffstats
path: root/textproc/website/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/website/Makefile')
-rw-r--r--textproc/website/Makefile35
1 files changed, 27 insertions, 8 deletions
diff --git a/textproc/website/Makefile b/textproc/website/Makefile
index 8fd44ec87a02..445be3b03522 100644
--- a/textproc/website/Makefile
+++ b/textproc/website/Makefile
@@ -1,14 +1,9 @@
-# New ports collection makefile for: website
-# Date Created: 2003-11-10 10:13:49
-# Whom: Jean-Baptiste Quenot <jb.quenot@caraldi.com>
-#
-# Based on the docbook-xsl port
-#
+# Created by: Jean-Baptiste Quenot <jb.quenot@caraldi.com>
# $FreeBSD$
-#
PORTNAME= website
PORTVERSION= 2.5.0
+PORTREVISION= 1
CATEGORIES= textproc www
MASTER_SITES= SF/docbook/OldFiles
@@ -28,6 +23,9 @@ PKGDEINSTALL= ${WRKSRC}/pkg-deinstall
NO_BUILD= yes
XMLCATMGR= ${LOCALBASE}/bin/xmlcatmgr
CATALOG_PORTS= ${XMLDIR}/catalog.ports
+CATALOG_XSL= ${WRKSRC}/catalog
+
+DXVERSIONS= current 2.2 2.3 2.4.0 2.4.1 2.5.0
post-extract:
${FIND} ${WRKSRC} -name '.#*' -delete
@@ -38,8 +36,29 @@ do-install:
(cd ${WRKSRC}/example && ${TAR} -cf - . |\
${TAR} -xf - -C${EXAMPLESDIR})
.endif
+ ${XMLCATMGR} -c "${CATALOG_XSL}" create
+.for dxversion in ${DXVERSIONS}
+ ${XMLCATMGR} -c "${CATALOG_XSL}" add rewriteSystem \
+ http://docbook.sourceforge.net/release/website/${dxversion}/xsl \
+ "file://${PREFIX}/${INSTDIR}/xsl"
+ ${XMLCATMGR} -c "${CATALOG_XSL}" add rewriteURI \
+ http://docbook.sourceforge.net/release/website/${dxversion}/xsl \
+ "file://${PREFIX}/${INSTDIR}/xsl"
+ ${XMLCATMGR} -c "${CATALOG_XSL}" add rewriteSystem \
+ http://docbook.sourceforge.net/release/website/${dxversion}/schema/dtd \
+ "file://${PREFIX}/${INSTDIR}/schema/dtd"
+ ${XMLCATMGR} -c "${CATALOG_XSL}" add rewriteURI \
+ http://docbook.sourceforge.net/release/website/${dxversion}/schema/dtd \
+ "file://${PREFIX}/${INSTDIR}/schema/dtd"
+ ${XMLCATMGR} -c "${CATALOG_XSL}" add rewriteSystem \
+ http://docbook.sourceforge.net/release/website/${dxversion} \
+ "file://${PREFIX}/${INSTDIR}/schema/dtd"
+ ${XMLCATMGR} -c "${CATALOG_XSL}" add rewriteURI \
+ http://docbook.sourceforge.net/release/website/${dxversion} \
+ "file://${PREFIX}/${INSTDIR}/schema/dtd"
+.endfor
${MKDIR} ${PINSTDIR}
- (cd ${WRKSRC} && ${TAR} -cf - VERSION ${COPYDIRS} |\
+ (cd ${WRKSRC} && ${TAR} -cf - VERSION catalog ${COPYDIRS} |\
${TAR} -xf - -C${PINSTDIR})
post-install: